Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #1843

    Hi There

    I’m hosting all my images and videos on Amazon S3 to speed up the site’s loading times. Therefore I’m using the External Media function (under Add Image in WordPress) when inserting Thumbnail images for my portfolio entries.

    I understand that an image first has to be uploaded to the website’s server before it will create a thumbnail image automatically. So for the portfolio pages I’ve manually created the correct thumbnail size images so that they display correctly.

    But now I have a problem with the slideshow’s thumbnail images which is right underneath the homepage slideshow. Is there a way to create those thumbnails manually? The slideshow images are 940×440 and hosted on Amazon S3. Now the thumbnails underneath the slideshow doesn’t look that great because it directly uses the 940×440 image instead of an automatically created thumbnail which is in proportion.

    You can take a look at http://www.universityofmakeup.com/ to see the distorted thumbnails underneath the slideshow.

    I appreciate your advice.

    Kind regards,



    It’s possible if you modify kriesi_post_thumb.php and/or kclass_display_slideshow.php. It’s possible to hack into the image generation process and to control things via i.e. post meta values. But detailed instructions are beyond the scope of ths support forum.


    Hey Dude,

    Any chance you can expand on this slightly? We are having the same problem on http://www.gamefreaks.co.nz

    The thumbs have just stopped being generated, even if I turn of S3 I still get no thumbs?

    Has just started happening yesterday, and help would be great.



    Did you install any plugins? What happened before the thumbnail generation stopped?


    we shifted servers, not 100% sure we loaded all required PHP modules, is there a specific module required to do the thumbnailing?


    sorted, was missing the gd-php5 module


    Glad that you solved the problem.

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Thumbnails Not Creating For External Media’ is closed to new replies.