Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #250198

    My themebuilder of choices theme doesn’t work anymore.

    Public site is ok, page with dynamic layout working correctly, but in the admin area when i click on template builder there are no templates defined and i can’t create a new one (button disabled).

    In the upper menù i see under “Template Builder” the correct list of my dynamic templates but when i click on one of these nothing appens (i jump in the disabled page of the template builder).

    Wordpress 3.8.2
    Choices theme version 1.7 (but i tried even with the 2.0 version i another directory).
    I tried with all plugins disabled.

    What can i do?


    Another hint:

    jquery-ui-sortable not loaded.

    In HTML of the template builder page i see:

    <script type=’text/javascript’ src=’,jquery-migrate,utils,jquery-ui-core,swfobject,thickbox&ver=3.8.2′></script>

    i don’t see scipts “media-upload” and “jquery-ui-sortable” seen in class-adminpages.php



    Thank you for using the theme!

    We would like to see the actual website, post the website url here. And if possible, please update the theme to the latest version so we could eliminate that factor while debugging.



    Site Url:

    I can’t update permanently the theme now, but i planned this switch next week accordingly with the customer fo the website permission.
    However i checked temporary with Choiches theme version 2.0 and the problem is still the same. At this point i suppose that is not a problem of the theme but of the wordpress itself, it seems that dosn’t work wp_enqueue_script function (i tried to disable all pugins without success).




    That all sounds like the jquery update issue with 3.7 which should be fixed by updating. On your sub directory you may need to force refresh your local cache and any plugins that are caching things so all the scripts are getting updated correctly.



    No idon’t use any type of caching (no caching plugins or ohter server methods).

    I found that the HTML of the “Theme Builder” page (in admin area of wordpress) is incomplete but the HTML code of the page “Theme Options” is ok.

    Maybe a template is corrupt?

    Can i parse the content of the “avia_options_choices_dynamic_pages” row in wp_options table?

    a:10:{i:0;a:6:{s:4:”slug”;s:13:”partner-media”;s:6:”parent”;s:9:”templates”;s:4:”icon”;s:30:”layout_header_footer_3_mix.png”;s:5:”title”;s:13:”Partner-Media”;s:9:”removable”;s:20:”remove this template”;s:8:”sortable”;s:13:”avia_sortable”;}i:1;a:6:{s:4:”slug”;s:14:”partner-musica”;s:6:”parent”;s:9:”templates”;s:4:”icon”;s:30:”layout_header_footer_3_mix.png”;s:5:”title”;s:14:”Partner-Musica”;s:9:”removable”;s:20:”remove this template”;s:8:”sortable”;s:13:”avia_sortable”;}i:2;a:6:{s:4:”slug”;s:14:”partner-eventi”;s:6:”parent”;s:9:”templates”;s:4:”icon”;s:30:”layout_header_footer_3_mix.png”;s:5:”title”;s:14:”Partner-Eventi”;s:9:”removable”;s:20:”remove this template”;s:8:”sortable”;s:13:”avia_sortable”;}i:3;a:6:{s:4:”slug”;s:11:”partner-web”;s:6:”parent”;s:9:”templates”;s:4:”icon”;s:30:”layout_header_footer_3_mix.png”;s:5:”title”;s:11:”Partner-Web”;s:9:”removable”;s:20:”remove this template”;s:8:”sortable”;s:13:”avia_sortable”;}i:4;a:6:{s:4:”slug”;s:18:”partner-altriamici”;s:6:”parent”;s:9:”templates”;s:4:”icon”;s:30:”layout_header_footer_3_mix.png”;s:5:”title”;s:18:”Partner-AltriAmici”;s:9:”removable”;s:20:”remove this template”;s:8:”sortable”;s:13:”avia_sortable”;}i:5;a:6:{s:4:”slug”;s:8:”homepage”;s:6:”parent”;s:9:”templates”;s:4:”icon”;s:30:”layout_header_footer_3_mix.png”;s:5:”title”;s:8:”Homepage”;s:9:”removable”;s:20:”remove this template”;s:8:”sortable”;s:13:”avia_sortable”;}i:6;a:6:{s:4:”slug”;s:17:”rete_dei_festival”;s:6:”parent”;s:9:”templates”;s:4:”icon”;s:30:”layout_header_footer_3_mix.png”;s:5:”title”;s:17:”Rete dei Festival”;s:9:”removable”;s:20:”remove this template”;s:8:”sortable”;s:13:”avia_sortable”;}i:7;a:6:{s:4:”slug”;s:22:”partner-espositori2013″;s:6:”parent”;s:9:”templates”;s:4:”icon”;s:30:”layout_header_footer_3_mix.png”;s:5:”title”;s:22:”Partner-Espositori2013″;s:9:”removable”;s:20:”remove this template”;s:8:”sortable”;s:13:”avia_sortable”;}i:8;a:6:{s:4:”slug”;s:17:”partner-media2013″;s:6:”parent”;s:9:”templates”;s:4:”icon”;s:30:”layout_header_footer_3_mix.png”;s:5:”title”;s:17:”Partner-Media2013″;s:9:”removable”;s:20:”remove this template”;s:8:”sortable”;s:13:”avia_sortable”;}i:9;a:6:{s:4:”slug”;s:20:”partner-edizione2013″;s:6:”parent”;s:9:”templates”;s:4:”icon”;s:30:”layout_header_footer_3_mix.png”;s:5:”title”;s:20:”Partner-Edizione2013″;s:9:”removable”;s:20:”remove this template”;s:8:”sortable”;s:13:”avia_sortable”;}}


    Ok if i empy this option (avia_options_choices_dynamic_pages) all work, but obviously i lost my templates.

    There is a method to reset templates or i must only clear “avia_options_choices_dynamic_elements” and “avia_options_choices_dynamic_pages”?


    Sounds like something got corrupted at some point in that case. I don’t know of any way to salvage the templates if the data is corrupted unfortunately.



    Yes, unfortunately you can’t sanitize the template data. I recommend to restore a complete database backup (delete the database content and import the backup sql file).

    Best regards,

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.