Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #206540

    When creating templates with the template builder and setting it with a right or left sidebar, the template layout breaks.

    The sidebar (left or right) does not appear beside the post content; it falls below. There is a Predefined Template “Right Sidebar” however, since I’m trying to customize the template I can’t use the pre-defined ones and have no idea how to duplicate them and addon to them.

    I’m not sure if it’s because I’m using the template system wrong or if it’s a CSS issue; but it’s driving me bonkers. Any help would be appreciated.

    #206541
    This reply has been marked as private.
    #206629

    Hi!

    It looks ok on my end. The sidebar doesn’t fall below the content. This is what I see:

    Can you please post a screenshot?

    Regards,
    Ismael

    #206630

    Hi Ismael,

    Sorry about that, we’re getting ready for launch and I switched it to the “global template”. I have now changed it back to using the custom template and you should now be able to see the sidebar issue that I was talking about in my original post.

    Thanks

    #206685

    Hi!

    Please try this, edit template-dynamic.php, find this code:

    if($template->check(0) == 'heading' || ($template->check(0) == 'page_split' && $template->check(1) == 'heading' && $template->check(2) == 'page_split'))
    	{
    		$layout = "alpha ";
    	}

    Replace it with:

    if($template->check(0) == 'heading' || ($template->check(0) == 'page_split' && $template->check(1) == 'heading' && $template->check(2) == 'page_split'))
    	{
    		$layout = "alpha eight ";
    	}

    Best regards,
    Ismael

    #206954

    That pulled the sidebar back up but now it’s not honoring the page splits/boxed styles.

    #207193

    Hey!

    Try re-downloading the initial theme files and then updating the parent theme. I don’t know what version that is since you’ve removed the version number but it isn’t the most recent as it doesn’t have at least one of the changes I wrote for 1.3.

    Best regards,
    Devin

    #207202

    Hi Devin,

    I’m actually using version 1.3, at least that’s what the download files from themeforest say and I haven’t gotten any recent notification about other version changes.

    Cheers.

    #207292

    Hi!

    @creative.collab: I’m sorry I removed the page split elements on the dynamic template. I thought it is an old issue with the sidebar not showing when you add a Page Split elements. Please try to add it back.

    Best regards,
    Ismael

    #207345

    Hi Ismael,

    Adding the page splits back bring back the styling issue; even after making the code change listed above.

    Cheers

    #207350

    Hi,

    Sorry i have a question about the design of your website. How do you do to have phone’s icon (or letter’s icon) on the border of the box? That’s pretty nice.

    #207358

    @alexandredb

    It’s done using the “Icon Box (Icon on Top)” shortcode, you can access it from the “Insert Shortcode” icon on your post editor. The basic shortcode inserts something like this:

    [iconbox_top title="Title Here" icon="Expose.png"]content goes here[/iconbox_top]

    Cheers,

    #207361

    oups i found: Box with Icon et i place it on top.

    Thanks

    #207641
    This reply has been marked as private.
Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘Template Builder – Sidebar Issues On Unique Page Layouts’ is closed to new replies.