Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #19492

    Hi guys,

    I just recently began to migrate my WP sites to a central location at WP Engine. I’ve created a multisite install and created my sites / imported my content. I have a single license to Choices and Angular. I’ve installed them and activated them within my network of sites.

    On one site I’m using choices, and on another I’m using angular. The site using choices has a broken template builder. I can add templates, but I can’t arrange /chose the element arrangements on them. ie. When I select “front page” as a template I see a blank area where the elements to arrange usually are located (text area / call out, portfolio, horizontal rule, heading + subtitle, etc).

    HOWEVER everything is working properly in the Angular theme.

    I’m running the latest version of WP. Are there any known plugins that might cause this for Choices and not Angular?




    Try to deactivate each plugin one at a time, see if you can find what is conflicting with the template builder. If it doesn’t bother you, try to install the Choices theme again or try to setup WordPress again.




    Thanks Ismael,

    I network deactivated all of the plugins on the site to no avail. I also reinstalled Choices. Nothing. At this point it’s too late to reinstall my WordPress multisite, but I don’t think that’s the issue anyway… Angular works just fine. Has anyone else reported this same problem?


    I am having this issue too. Ishmael is trying to resolve it but it might be a tough one.


    Hey maverick3x6,

    I’ve tagged Peter on the issue as well as Kriesi. I know Kriesi uses a MU installation for all of the theme demos so I know the themes work in that kind of a set up I just don’t know if there are any particular hoops you need to jump through to get one or the other working.





    maverick3x6 – please create me a wordpress admin account and send me the login data to: (Email address hidden if logged out) – I’ll look into it.

    Best regards,




    I’m sorry there is one important detail I forgot to mention is that I’ve created a child theme for Choices. To be honest, I forgot I did that myself. Before I go wasting your time Dude, I’ll inspect further. I deactivated the choices child theme and activated the Choices parent and it worked fine.

    Are there any known issues with Child themes that prevent the settings from working properly? Perhaps it’s something I did in the code…



    Not any known issues though I never recommend child themes for any theme with as much backend customization options as Choices or most of Kriesi’s themes have. You can use the custom.css file to easily load in any custom css and for those occasions where you want to edit the actual theme files, it would be better to just modify the theme files and keep a change log for when you update.




    hm, just did a quick test with a child theme and it worked fine…

    you might want to make sure that the child themes name does not use special characters. other than that if used correctly I working with a child theme shouldnt be a problem…



    Thanks for everyone’s help on this issue. You found the solution. I overlooked a hyphen in the child theme name that was causing the issue. -_-

    Sorry about that.


    It’s interesting that you don’t recommend child themes, you’re the only person thus far who hasn’t. I understand exactly where you’re coming from, but in terms of efficiency I plan to have a few installs of customized Choices themes in my multisite install (don’t worry I’ll buy the multiple licenses ;-)). When Choices is updated I’d rather just replace the parent, rather than manually update the customized Choices themes since I plan on altering the .php files differently for each one.

    Thanks guys!



    Glad that we could help you :)



Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Template Builder not working in Multisite’ is closed to new replies.