Viewing 30 posts - 1 through 30 (of 50 total)
  • Author
    Posts
  • #912908

    Hi
    As a title, I notice a moderate decline of the sharpness of my images when I load them on the site
    Premising that before uploading photos on the site I make the post production where I perform a standard procedure and when I display them on my computer I see them clear enough
    After loading on the site the images are soft
    Where am I wrong?
    Best regards,
    T.

    #913484

    Hey Tonci-M,

    WordPress compresses images on upload.
    You need to decrease WordPress image compression. Here is how to do it:
    http://www.wpbeginner.com/wp-tutorials/ (Purchase code hidden if logged out) -wordpress-jpeg-image-compression/

    If you need further assistance please let us know.
    Best regards,
    Victoria

    #913609

    Hi Victoria,
    I saw the video tutorial and I went to functions.php but exactly where I have to paste the code

    add_filter(‘jpeg_quality’, function($arg){return 100;});
    ?
    If I paste it on the wrong place it will not work…
    Can you please help me?
    Best,
    T.

    #913842

    Hi Tonci-M,

    You need to use a child theme and in the child theme, the file is clear so you can put the code right after the comments.

    In the parent theme try putting after
    if(isset($avia_config[‘use_child_theme_functions_only’])) return;

    You will need to reupoad the images too.

    If you need further assistance please let us know.

    Best regards,
    Victoria

    #913851

    Hi Victoria,
    Child theme? what is it? where can i found that?
    Best,
    T.

    #913863

    Hi Tonci-M,

    Here is a tutorial for you

    If you need further assistance please let us know.
    Best regards,
    Victoria

    #913883

    Hi Victoria,
    I think this is too complicated for me …
    If I provide you with my log credentials, would you be so kind as to do it for me?
    I hope it’s not too much to ask
    You see, my English is extremely weak, in fact to communicate with you I use the translate
    Let me know something
    Thanks!
    Best,
    T.

    #913918

    Hi,
    To install a child theme, please include ftp access in the Private Content area.

    Best regards,
    Mike

    #914046

    OK

    #914220

    Hi,
    With Filezilla I recived:
    user:ok
    password:failed
    Please check.

    Best regards,
    Mike

    #914498

    Sorry, my mistake…

    #914617

    Hi,
    Sorry, that is not working either.

    Best regards,
    Mike

    #914976

    Hi Mike,
    Ok, let’s see if I did everything right.
    I logged in to my hosting provider Site ground (https://www.siteground.it/)
    Then I went to my C panel – File – FTP Account
    I created the account with the credentials that you can find in the private area
    If something is wrong, please let me know
    Many thanks,
    Best,
    T.

    • This reply was modified 1 year, 7 months ago by  Tonci-M.
    #915150

    Hi,
    The second one is working because it has your domain after the @
    but the directory is empty, looks like you need to set the directory to “public_html”
    Please see: How to create FTP accounts
    Perhaps allowing us access to your cPanel would be easier?

    Best regards,
    Mike

    #915646

    Hi Mike,
    Yes, that will be much easier for me, many thanks!

    Best,
    T.

    #915827

    Hi,
    I created a child theme for you and installed it. I also copied your theme settings over. Please clear your browser cache and check.

    Best regards,
    Mike

    #916295

    Hi Mike,
    Thanks for your help.
    However there are the problems.
    I found a short story about me on all the pages while before it was only on the page About
    I solved this by myself and so there are no problems
    With Ismael we managed to create the widget “Latest updates” dedicated to the portfolio page that worked well, every time I updated a page of my portfolio the widget put it in the first place, now this thing no longer works, moreover I added more than 12 selected categories but only 11 continue to appear.
    To return to the main problem, the sharpness of the images, I continue to see them soft
    Please let me know what are the next steps
    Best,
    T.

    P.S. Solved widget latest updates, in the portfolio categories page somehow nothing was selected, now working fine.

    • This reply was modified 1 year, 6 months ago by  Tonci-M.
    #916460

    Hi,
    Ok, so then the child theme issue is solved? I see Victoria was assisting with the sharpness of the images, and you tried with the code she recommended?

    Best regards,
    Mike

    #916802

    Hi Mike,
    As I wrote more up I did not add any code because I did not know where it goes.
    Can you tell me where it should be inserted correctly?
    Best,
    T.

    #917083

    Hi Tonci-M,

    Now that you have the child theme, you can add the code from the tutorial to your child theme functions.php.

    Best regards,
    Victoria

    #917122

    Hi Victoria,
    Can you be a little more precise?
    In the functions.php there are codes that arrive at column 12
    Do I have to paste it down? Column 13?
    Best,
    T.

    #917503

    Hi,

    You can paste it anywhere that there is nothing else inside.
    The last lines are always the best place.

    Best regards,
    Basilis

    #917569

    Hi Basilis,
    No, it does not work,
    The photos appear at the bottom, you only see the top, so it’s not good.
    Not even other pages work, they all look different and wrong,
    This if I stay with Flashlight child, if I go back to Flashlight everything goes back to normal but the images remain soft.
    I also tried to delete and reload the images but nothing changes
    Please take a look.
    Best,
    T.
    P.S. Can you can make me understand how to attach a screenshot, it would be easier to make you understand what happens

    If it helps, I resize all my photos at 1000px per long side

    • This reply was modified 1 year, 6 months ago by  Tonci-M.
    #918145

    Hi,

    Thank you for the update. We added the filter in the functions.php file.

    add_filter('jpeg_quality', function($arg){return 100;});
    

    Please regenerate or re-upload the images to see the effect. You can use one of these plugins.

    // https://wordpress.org/plugins/force-regenerate-thumbnails/\
    // https://wordpress.org/plugins/regenerate-thumbnails/

    Best regards,
    Ismael

    #918279

    Hi,
    I installed plugins that you sent me, I deleted and reinstalled the images from a random page belonging to Portfolio to see the effect
    Always the same, the images are soft
    I tried to activate the Child theme but it’s even worse, the images open badly, you can not see them, the gallery images are very small, the other pages are completely different …
    Maybe I did something wrong, I read in the reviews that some have had to wait a few minutes but to me plugin installed in a flash, no loading bar
    Let me know something about.
    Best,
    T.

    #918874

    Hi,

    Please provide an original image and we’ll try to upload it. Where are you checking this? Please provide an actual link to the page or post as well.

    Best regards,
    Ismael

    #918893

    Hi Ismael,
    After making the changes, I deleted and reloaded the images from the “Mammals” page found on the Portfolio page of my site.
    Mammals
    If you tell me how I can attach an image directly from the computer I will do it
    Let me know if you need some other things
    Best,
    T.

    #919549

    Hi,

    You can upload the image on dropbox and imgur or send it directly to this email. ( see private field )

    Best regards,
    Ismael

    #920230

    Hey!

    I received the original image on my email and compared it from the uploaded one but I can’t really see much difference. Maybe, my eyes are not “trained” like yours.

    This is what I see: https://imgur.com/a/WxBHR

    Best regards,
    Ismael

    #920271

    Hi Ismael,
    I can see only a black screen, no images there…
    Now I send you a screenshot (via WeTransfer) where 2 images appear, the first on the left is opened by my computer, the second on the right is the one that appears on the web (my site)
    You will notice immediately the different dimensions, I think that the Flashlight page somehow enlarges the real size of the images, for that reason it is not seen as clear as it should.
    Can you do something?
    It’s great for me that the images appear smaller, even though they are clearer
    Best,
    T.

Viewing 30 posts - 1 through 30 (of 50 total)

The topic ‘sharpness of the images’ is closed to new replies.