Tagged: 

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #363053

    The only real problem I have never been able to solve with my website involves the permalinks. When I set up my website I didn’t know the importance of this, and left it set at the default, so all my website pages have addresses like http://www.mywebsite.com/?page_id=1884. I want it to be something like http://www.mywebsite.com/about and http://www.mywebsite.com/contact

    I’ve tried some plugins that say they can fix everything on my website to use the custom permalinks I want, but nothing works.

    I’ve tried going to Dashboard/Settings/Permalinks and setting it to Custom Structure with http://www.mywebsite.com//%postname%/ but then when I try to go from my index page to, for example, my About page, it takes me to http://www.mywebsite.com/index.php/about/ and the page just displays “No input file specified.” Notice that “index.php” gets included in that address, and I think that’s why it’s not working.

    I think I’m close, but I cannot figure out how to get “index.php” out of that last address, so it can take me to the actual About page.

    #363355

    Hey Arkansawyer!

    If you select just the postname option and save then it should be working.

    Does WordPress give you a message saying “Permalink structure updated”. Or does it say something else?

    Let’s try deactivating all plugins and then delete your .htaccess file and save your permalinks once more.

    Best regards,
    Elliott

    #363430

    Thanks. I agree, it SHOULD be working, but alas…
    Here is what I was getting before I deleted .htaccess:

    When I set Permalinks to “default” and click save, WP returns “Permalink structure updated.”

    When I set it to “Custom Structure” /%postname%/ and click Save, WP returns “You should update your .htaccess now.” and below that…
    If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /index.php/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php/index.php [L]
    </IfModule>

    So now I have done as you suggested. I deactivated all plugins and used FTP to delete the .htaccess file (in the root directory where the index and all the htm files are stored). Then I again saved the permalink custom setting as /%postname%/. Again WP returned “You should update your .htaccess now.” and the other info above regarding “If your .htaccess file were writable, we could do this automatically…”

    In other words, nothing changed after I deactivated plugins and deleted .htaccess

    And when I check the website it’s still the same problem. All my pages have “index.php” inserted into their permalink name, so for example, instead of saying http://www.mywebsite.com/about, it says http://www.mywebsite.com/index.php/about and when I try to go to any page other than index, the pages display “No input file specified.” (well, for some reason SOME of them give the message “you can find this page at http://www.mywebsite.com/?page_id=xxx where xxx is a number, different for each page)

    Interestingly, if I manually remove “index.php” from the URL and go directly to http://www.mywebsite.com/about, it takes me to a pages that says “404 (Page Not Found) Error.

    The only way I can get to my real About page is to turn things back to the default permalink structure and go to http://www.mywebsite.com/?page_id=1884

    NOTE: After deleting .htaccess, there is now NO .htaccess file showing up. I would have thought after deleting it, it would be recreated or something. Then I investigated it and saw that .htaccess exists in several directories. The one I deleted was in the root directory of the website, where the index and all the htm files are stored. Was I supposed to delete .htaccess file in some other directory, like wp-admin?

    Thanks so much for your help!!

    #363921

    Hi!

    See here, http://codex.wordpress.org/Using_Permalinks#Fixing_Permalink_Problems, perhaps your server has mod_rewrite disabled.

    In this case you can just create the .htaccess file manually and add the code WordPress gives you inside and save.

    Best regards,
    Elliott

    • This reply was modified 4 years, 6 months ago by  Elliott.
    #364003

    It wasn’t quite as easy as just creating the new .htaccess file, but thanks to your help, I am there!

    After I created the new .htaccess file, it was STILL putting “/index.php” in the middle of all my menu links, so none of them worked, but I manually removed that on each menu item and now everything works and I can go to my FAQ page with http://www.mywebsite.com/faq rather than http://www.mywebsite.com/index.php/?page_id=1574

    I have struggled with this for over a year, trying redirects, plugins, etc. Should have just asked for help long ago. Thanks so much!

    #364009

    Epilogue:

    The final problem solved! Under Settings/General under Site Address (URL) I just discovered that it said “http://www.mywebsite.com/index.php”

    I removed the index.php segment there and saved and now it no longer puts that in all my permalinks! So all my old blog posts are accessible (the final problem I had) and all is well.

    I guess this was my problem all along, in moving from the default permalinks to post name permalinks.

    Thanks again. 100% success!

    #364336

    Hey!

    Ahh I see. Thanks for posting your solution. Let us know if you have any other questions.

    Best regards,
    Elliott

    #1046006
    This reply has been marked as private.
    #1046146

    Hi _handson_,

    Please open a new thread and include admin login details in private so that we can have a closer look at your site.

    I’ll close this thread for now since it’s 4 years old.

    Best regards,
    Rikard

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Setting Custom Permalinks’ is closed to new replies.