Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1064263

    Hallo
    Gemäss Google Search Console sind 17 meiner gesendeten Seiten mit “noindex” gekennzeichnet. Ich habe schon alles versucht und den Quelltext mit Seiten verglichen welche indexiert wurden, leider habe ich den Fehler nicht gefunden.
    Es hat auch keine Logik, denn einige Seiten wurden idexiert und andere nicht, obwohl im Quellcode der gleiche Code ersichtlich ist.
    Haben Sie mir einen Tipp wo das “noindex” versteckt ist oder wissen Sie wo der Fehler ist?

    Vielen Dank für eure Unterstützung.
    Ivan

    #1065767

    Hey Ivan,

    Thank you for using Enfold.

    Those pages are indexable according to the markup.

    <meta name="robots" content="index, follow" />
    

    Have you tried setting or marking the entries as solve in your console? If ever they come back in the list then there is a problem.

    Best regards,
    Ismael

    #1087437

    Wir haben das Problem auch und möchten es sehr gerne abstellen.
    Bei uns handelt es sich um die Kategorie-Seiten: “Categories” of Portfolio
    Was müssen wir tuen um den Meta Eintrag der “Categories” :

    <meta name=”robots” content=”noindex, follow” />

    zu ändern in:

    <meta name=”robots” content=”index, follow” />
    danke.

    ==
    We also have the same problem and would like to turn it off.
    The problem exists in: “Categories” of Portfolio
    What do we have to do about the meta entry of the “Categories”:

    <meta name=”robots” content=”noindex, follow” />

    to change in:

    <meta name=”robots” content=”index, follow” />
    thanks

    #1088109

    Hi,

    Are you using any SEO plugin? This filter should define the meta robot tags for the category pages.

    if(!function_exists('avia_archive_set_follow'))
    {
        function avia_archive_set_follow($meta)
        {
            if( is_product_category() || is_shop() || is_archive() ) {
                $meta = '<meta name="robots" content="index, follow" />' . "\n";
            }
            return $meta;
        }
    
        add_filter('avf_set_follow','avia_archive_set_follow', 10, 1);
    }

    Just add it in the functions.php file.

    Best regards,
    Ismael

    #1089466

    Hallo

    Es wird kein SEO Plugin verwendet. Wir haben alle Plugins testweise deaktiviert. Das Problem besteht weiterhin.
    Implementierung des angegebenen Codes funktioniert nicht (nur weisse Seite angezeigt)
    mfg

    =====
    There is no SEO plugin used.
    In addition, we have disabled all plugins on a test basis. The problem is still there.
    Implementation of the specified code do not work (only white page displayed)
    greetinx

    #1089805

    Hi,

    Thanks for the update.

    Implementation of the specified code do not work (only white page displayed)

    Did you copy the code from your email? Please copy it directly from the forum. Or edit the following line if you’re not using WooCommerce:

            if( is_product_category() || is_shop() || is_archive() ) {
    
    

    Replace it with:

            if( is_archive() ) {
    

    Best regards,
    Ismael

    #1089862

    thank you.
    Der nachfolgende code löst das noindex Problem:
    The following code solves the noindex problem:

    functions.php

    
    if(!function_exists('avia_archive_set_follow'))
    {
        function avia_archive_set_follow($meta)
        {
               if( is_archive() ) {
                $meta = '<meta name="robots" content="index, follow" />' . "\n";
            }
            return $meta;
        }
        add_filter('avf_set_follow','avia_archive_set_follow', 10, 1);
    }
    
    • This reply was modified 1 week, 5 days ago by  hz2014.
    #1090245

    Hi,

    Great, I’m glad you found a solution and thanks for sharing. Please let us know if you should need any further help on the topic or if we can close it.

    Best regards,
    Rikard

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.