Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #1865

    I have a mental blank. This was working on my prototype site, but when I moved it into production the RSS feed button in the very bottom footer isnt working. Gets page not found error when i click on it. What did I break? And how do I fixit?




    It might be an issue with URL rewriting, is your prototype server the same as your production server?




    No; the production install is on a different server, different domain name.

    When I moved it, I did a search and replace on the DB SQL file for the domain name. Then copied the entire dir from prototype to new server.

    More info: The RSS Icon links to “http:manorpresbyterian.com/feed/” which is consistant with how i see it linked on most WP sites. But my /feed dir does not exist. I can easliy just create the dir in my root; but how do I make WP populate the data for the feed?


    Update: After a lot of googling, I discovered the problem. I have no posts on my site. All the pages are “pages” or portfolio items.

    If I add one test post; then the RSS feed works; but it only produces a feed for “Posts”. How to make WP populate the rss feed for portfolio items and Pages?


    This thread answered my question and solved the problem:


    I read that before, but at the time I did not realize that natively WP only sends “Posts” to the feed.

    Making the code modification in the referenced thread solved my problem. Now portfolio pages are in my feed. :)



    Great glad to see that it worked out for you. Thanks for purchasing Avisio.

    Best regards,


Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘rss not working’ is closed to new replies.