Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #2112

    On the main page options, under “Additional Page Content”, the “Read More” tag I placed on the linked page is not working correctly.

    I am using: <!–more–> after the first phrase of my About Us page, but instead of the Read More button, all I get is the FULL story/content of that link displayed on the Main Page.

    I even tried replacing info on the dummy page (which seemed to work just fine right before I replace info with my own content). Still no luck.

    Any ideas on what went wrong?

    Note: I DO have the Read More button on other sections of the page i.e. columns below the “featured area” under slider.

    The area next to testimonials on main page is the only one that seems to be giving me troubles.


    Can you double check that you are following this rule:

    No whitespaces are allowed before the “more” in the <!–more–> quicktag. In other words <!– more –> will not work! –


    Thanks Noah. Quicktag doesn’t have whitespaces.

    But funny enough, the problem seems to be solved now. Perhaps it was a bug from my last browser session (Chrome).

    Now that I tested on IE8 and tried a new Chrome window, my beloved Read More button is displaying!

    Thanks for your quick reply!


    Arrrrrrgh! I celebrated to soon! :(

    Here is the deal: It’s not the browser, it’s not the quicktag…It’s the 4-column section under the sliding box!

    If I use “posts” to personalize the content on each of those columns, things work fine.

    But as soon as I use “Page” content for the 4th column, the lower section of the page goes wacko, ignoring the <!–more–> quicktag that I assigned on that page.

    If I switch back to “post”, the lower section behaves normally, I get my Read More button back.

    Would this be something I can fix or is it a real bug that needs Kriesi’s attention?



    It’s very likely that it’s a theme bug because some user already mentioned this problem. I’ll report it to Kriesi.


    Thanks guys!

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Read More Button not displaying correctly’ is closed to new replies.