Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #19017


    I’ve had this problem before and managed to fix it. After a server crash and updating my theme, I’m having this problem again and can’t figure it out this time.

    The “Newest items” slider on my front page is not showing the newest items. I can’t figure out why it is showing the items it is. I have 3 parent categories each with a few child categories. I’ve tried just selecting the child categories in the template builder for the frontpage template, along with selection child and parent. Nothing I do changes the items showing on the front page. It is pulling items that are several months old. And, even then, they are not in sequence of publishing date. So, I’m not sure yet what it’s using to pull them.

    Can someone help me figure this out?

    Update 1: I just realized the products are being ordered by reverse alphabetical order if that helps

    Update 2: Also related… I had items set to 12, but it was only showing 10 (4, 4 and then 2). I moved it to 16, and now it shows 12 total items (4, 4 and 4). Not sure what that is about? I then set it to only show 1 category, and to show all items. It ends up displaying 17 out of 29 (4, 4, 4, 4 and 1).

    Update 3: I updated my files to 1.6 just to make sure that wasn’t it. It didn’t fix anything. But, just a point of clarification, is the folder indicated in the changelog as “folder: config-woocommerce” actually the “woocommerce-config” folder?



    Hi e,

    Make sure you are working with the most recent version of WooCommerce and try disabling all other active plugins.

    If you’ve updated to 1.6, also try removing the product element from the frontpage template, saving it, then re-adding it with your options again.




    I tried the above, to no avail. However, then I stumbled across the “default order” setting in the WooCommerce->Settings->Catalog page. Changing this to publishing date fixed the ordering problem on the front page. But, now my product pages are ordered by publishing date as well where I’d like them to continue to be ordered by alphabet. Any help?


    Okay, after more research, I set the woocommerce setting back to alphabetical, and then added this to the helper-template.php file:

    //Following line forced the front page to order by date

    $order = “date”;

    This seems to work.



    Glad that it works now :)



Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Products slider not showing newest products’ is closed to new replies.