Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #213559

    Hi there,

    I have an issue with the product variation drop downs not refreshing when I select them. See this link:

    The data select is working, because it updates the price and when added to basket it puts the right data in the basket. However the drop downs arent showing the right selected value when clicked. You will see this in an example on the link above. If try and select, say the 8th size option, its still will say the first. Same with the other drop down.

    I have updated the theme just now and still has not resolved. I think the theme is the problem because when I activate the default twenty 12 theme the dropdown work fine. Its possible a Jquery issue somewhere.

    I have alos updated WooCommerce.

    Please advise


    Hi silvermarbles!

    Please refer to this link: (Purchase code hidden if logged out) -any-longer/#post-180740

    Remove browser cache then reload the page.

    Best regards,


    I have the same issue. I tried going to

    I was unable to replace
    el.bind(‘change’, function()
    jQuery(document).on(‘change’, this, function()

    Can you give more information about how to do this?



    That code is exactly at line 118, simply replace it. If you can’t do that, here’s the modified file:



    Hi Josue

    I managed to change the code, but it hasn’t fixed the problem.

    Any other suggestions?



    Please check it again – when I view the code in the web browser it looks like

    jQuery(document).on(‘change’, this, function()

    but it should look like

    jQuery(document).on('change', this, function()

    Best regards,


    Hi Peter,

    I tried to change it in File Manager and also using an editor plugin, but it still is not working.

    I’m not sure why you are seeing those strange characters or where to go to try and change them.

    Sorry, I’m not brilliant at the coding side of things.



Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Product Variations Drop Down issue’ is closed to new replies.