Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
  • #23655

    Just upgraded my clients theme and her products are not showing on the single product page. Was working fine before. You can see them on the main products page but when you click details, nothing shows up.

    Main Products page (works fine)

    However when you go to view product details, this is what I get; (Purchase code hidden if logged out) /


    Hi lynewman,

    I don’t see WooCommerce being loaded in properly. What version are you using of the plugin?

    It seems to be failing right after loading the price which may be a plugin conflict or something like that. So you could also try deactivating any active plugins outside of woocommerce after updating WooCommerce itself.




    I am using Version 2.0.10 and I deactivated all but woocommerce and same thing.


    By the way, when I switch over to another theme it works…so not sure what is going on


    I really need some help with my client’s site. I reinstalled – everything is up to date like before but still does not show individual product pages. I deactivated all plugins – still does not work. If I switch theme to Twenty Twelve the pages work and load. Only when I switch to Abundance theme they are not loading.

    Thank you ~Lori



    Can you please update each Product one at a time? Test one product, update it. There are instances where you have to update each product to make them work again.




    Okay, I went through and updated each product, still not loading. I deleted all cache as well.


    I’m having the same problem with our live site but it works fine in our staging env. Click on the product once you land on the packages page:



    I’ve switched themes (2012) and it works. I’ve created net new products and the problem persists.


    I should add that this problem happened with both the 1.6.6 and the 2.0.10 versions of woocommerce.


    Somewhat relieved it’s not just happening to me… I have re-installed woocommerce, theme etc. Still have not found the solution for my client.


    It looks like somehow the content after <!-- ####### MAIN CONTAINER ####### --> is not loading (although, lynewman has a couple of lines of code where I have none).


    Does anyone know anything? My client is getting anxious but initially we had no problems with this site, it’s only recently during a recent upgrade that we have experienced problems.


    @farenagency – please update to theme to the latest version.You’re using an outdated version (1.0) which is not compatible with WC2.0.x. or 1.6.6.

    @lynewman please also try to install the latest version. It seems like some files are outdated (woocommorce-mod.css, etc.).


    @dude – You’re the man! I deleted the old theme and uploaded the latest version and that fixed it! Thanks so much, I truly appreciate it and my client will be thrilled.~Lori



    Great – glad that I could help you :)



Viewing 15 posts - 1 through 15 (of 15 total)

The topic ‘Product Pages Not Showing’ is closed to new replies.