Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #17019

    This problem occurs every now and then. The products are in the admin sections but when I view the products page, i get this msg,

    “Fatal error: Class ‘WC_Product’ not found in /home/content/16/9626716/html/wp-content/themes/propulsion/config-woocommerce/config.php on line 471”

    I have deactivated / deleted / reinstalled / upgraded / downgraded and all seem to give me the same problem. sometimes it would cause a 500 error and affect then whole site.

    here is a link to the page,

    Any help or info is appreciated.



    A strange error. the line in question :

    $product = &new WC_Product( $post->ID );

    Probably php4 ‘pass by reference’ is not being handled by your apache php5 config file. Easiest thing to do would be to change that line

    to read:

    $product = new WC_Product( $post->ID );

    Basically removing the & symbol before the word ‘new’. If you see something similar again, please remove the ‘&’ symbol before ‘new’ on that line.


    Please let us know how it went.




    just deleted the “&” and same issue occurs.



    I was able to replicate the error … but only when I used WooCommerce version 1.321 as you are. However when I use the current version of the plugin 1.652, the error is no longer present.




    just upgraded and now it’s a 500 Internal Server Error and all pages are affected.


    Hi jackchin,

    If you can, disable woo commerce from the admin area of wordpress. If you can not, the FTP to your wordpress installation and just delete the woo commerce plugin folder in wp-content>plugins.

    Now, replace the config.php file in the propulsion theme was edited to get you back to the starting point and make sure everything is working ok. Go ahead and disable all other plugins at this point.

    Now, if you are not running the most recent version of WordPress, update to the most recent version from you wordpress dashboard.

    Once done, make sure everything is still working ok. Now you can search for and then install the WooCommerce plugin so that you have the most recent version. All your product information and settings should still be there.

    Check to see if you are still getting the same error as before and let us know.




    The complete upgrade seemed to have worked. Thanks guys!



    Happy to see that Devin got you back in the game.



Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Problems with woocommerce, no products display (praduct & frontpage)’ is closed to new replies.