Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #22095

    When I use bbPress with propulsion, public forums appear OK, but private forums show ‘404’ page not found error. The forum exists OK in the admin panel. If I change the forum to Public it works OK. Any ideas?


    Hi silvercreekvalley,

    Try going to the WordPress Settings>Permalinks and changing them to default and see if that fixes the issue. You can then try switching back to what you had before to see if just refreshing things works.




    Hi Devin,

    Sorry – no it makes no difference. I tried running in default, and then switching back, refreshing links, etc. Anything else I could try? I’m familiar with PHP so can get into the code if necessary.



    What version of Propulsion are you using. I am using 1.91, and created a private forum with no problems and it’s showing up ok. How’s your settings and permalinks? I left everything as default for bbpress settings and /%postname%/ for permalink settings.

    The url is a bit funky to this page :

    But first try all went well..I have WooCommerce running as well.

    Just in case i reset wordpress and tried again, and also no problems




    I’ve disabled most of my plugins except the ones that are essential and still no luck. Its just a standard wordpress install (latest wordpress). How do I determine the version of propulsion I’m using – I think I’m up to date. I dont use WooCommerce.



    Check the top of style.css by viewing source, or by looking in the root theme folder. Its right on top.




    Just tested it myself and it also works fine. Since we are about to release a new version you might want to wait a day or two and then upgrade to the version I will push to themeforest within the next 24 hours :)


    Thanks – I’ll try with the latest theme. I’m keeping all my forums public (visible) for now. I’ll dig into the PHP code to see if I can find the trip point.

    Where is the version given by the way in the propulsion install.



    There is no trip point. BBPress works with the theme. Not sure what version you use, so just download the latest one from and as you saw, all is well. The latest is probably 1.92 since at the time I was using 1.91.



Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Private forums dont work with bbPress 2.2 or 2.3’ is closed to new replies.