Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #16833

    Hi. I’m sorry but I am still having problems with the portfolio.

    This page:

    The blue visit website button on the thumbnail points to an external link but opens an internal one.

    I need to disable the link on both the thumbnail photo and the text underneath which reads Lighthouse Lodge.

    I also need to disable the hover effects on the thumbnail.

    And I need the link from the button to open the external link.

    Thank you.




    Here is a video I just slapped together that tells you how to do most of it. The link will require editing of the templates to change, may be easier to just remove it the same way I did in video with the overlay. Unfortunately there is another piece to the overlay that has to be removed as well.




    Hi Nick. Thank you so much for that. Nobody from any WP support has ever gone to so much trouble before – and I have bought a lot of WP themes. I was almost about to give up but you have rekindled the flame. I know you went to a lot of trouble so hope you are not too peeved to hear that I have kind of reverted to the default.

    Here is the page now:

    I still have a few problems.

    1: When you click on a thumbnail it opens with an image, a title and a description. I need to remove the link from the title. Having a link to a post here will just confuse people.

    2: Not sure how to reorder the portfolio items. Tried changing the publication dates.

    3: Some of the large images are being resized. Lighthouse Lodge (640×430) and Ashmur Villa (563×609) are rendering correctly. The 2 smaller photos – Beechwood (468×343) and Fairholme Apts (426×283) are not. Not sure why?

    Again, Many thanks. Mark.



    Sorry for the delay in answering. We aren’t regular WordPress support. We are the few, the proud, the Kriesi’s elite support team. :) We do appreciate the kind words though. Thanks!

    1) Changing the link is tricky, you will have to figure out yourself how to do that since a portfolio that completely points to some other website is something custom.

    I would just remove the title entirely, since its easier than rewriting the code. Try adding this to quick css in the backend

    H1.main_title {display:none}

    2) The portfolio is ordered by date, modifying it wont change anything since the entry date remains the same , just the modify date changes. Try this plugin , it will help you out.

    3) You need to set constraints. Please open up functions.php at the root of the theme. You will see

    $avia_config['imgSize']['portfolio_small'] 		= array('width'=>241, 'height'=>179 ,'copy'=>'greyscale');	// images for portfolio 4 columns

    This is where by the way you can remove the greyscale. So what you want to do is change it to

    $avia_config['imgSize']['portfolio_small'] 		= array('width'=>241, 'height'=>179 ,'crop'=>'true');	// images for portfolio 4 columns

    Try also with crop = false. Once you understand how aspect ratio works, you will get a better idea what’s going on here.

    Now also go to the backend of the theme, Settings > Media, and make sure you have the checkbox off. Also for maximum width and height put down 241 width and 179 height. Here is where you have to play around with the numbers. The Settings > Media and the functions.php are the two places controlling the thumbnails. Try some different things.

    You just have to remember that the original photo’s aspect ratio (height vs width) plays a key part. So if the original photo has 10 width and 200 height, and another has 200 height and 10 width, it is difficult to create a thumbnail that is square yet represents what the photo looks like, so you either have to crop it , or enlarge it (make blurry). Other wise you should use a program like Photoshop to prep the images first.




    Thank you Nick.



Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Portfolio Problem.’ is closed to new replies.