Viewing 30 posts - 1 through 30 (of 46 total)
  • Author
  • #13368

    Not sure if it was a WordPress update that caused this (I updated to version 3.4) but the pagination on my portfolio has stopped working. It was working fine last week. When I click on page 2 it re-loads page 1 so I have no access to page 2. I have tested on different browsers and the same issue occurs.

    Any ideas?




    Not sure what is causing this. Let me tag the rest of the support team.




    I’m experiencing the same issue since updating. Any help is greatly appreciated!

    Thanks in advance!


    Hi All,

    Try refreshing your permalink settings. Just go to Settings>Permalinks and change the settings to something else, save, then change them back and save 2-3 times. Its a bit of an odd bug, but its been with wordpress for a while and can sometimes happen.

    If that doesn’t work, try setting your permalink settings to the default setting and testing if the pagination works. If it does, there might have been a change on the server (htaccess file etc) that needs to be fixed.

    You can also try disabling all your active plugins to see if the update is conflicting with one of them.




    Hi, Devin,

    Thank you for your quick response. I tried all of those items and didn’t have any luck. This is a valuable feature for this particular theme. I hope to use Coalition and dump my current site in the near future, so any additional suggestions you may have are greatly appreciated.




    I have tried both the Permalinks idea and disabled all plugins but the problem still persists.


    Strange that you are both having issues. Does setting the permalink structure to default work for either of you?


    The default didn’t seem to change the problem for me. I just tried again, in a few browsers.


    Can you create a temporary admin account for me to take a look at whats going on?

    You can send the information to my email at DevinVinson (at) Make sure to include a link to this topic so that my spam filter doesn’t grab it :)




    Sent. Thanks!


    Please help. Experiencing the same issue. Wp 3.4.


    Can you try updating your theme to the newest 1.3.3 version available from your downloads on Themeforest. There was a compatibility fix and framework update that might be the fix for the issue.




    Can you please describe the fix? We made tons of customizations to the theme and it will destroy all of our work.


    I have only recently purchased the theme and have been running 1.3.3 both before and after this problem occurred.


    Any updates on this? Noticed the same issue on my site running WordPress 3.4. I wish I had noticed this thread before I upgraded as it seemed to work fine then.

    Is there anyway I can disable pagination in the meantime, and have my portfolio show all one a single page? Because right now it just doesn’t function as is.



    I am investigationg the issue. If I can reproduce it a fix will be available within the next few days :)

    I ll keep you posted!




    I found a fix: if you add the name of the page before, you go to the next page:

    example: the name of the page os ‘home’



    fabcom, could you describe this further? I’m not seeing a clear place (yet) to do this.

    Thanks in advance!



    Hey! Actually its a problem with the way wordpress 3.4 handles queries.

    I think I already found a good solution, so stay tuned, update will come this week ;)

    Best regards,



    My fix:

    Open function-set-avia-frontend.php.

    Line 571:

    $output .= ($paged == $i)? “<span class=’current’>”.$i.”</span>”:”“.$i.”“;

    Change to:

    $output .= ($paged == $i)? “<span class=’current’>”.$i.”</span>”:”“.$i.”“;

    HOME stands for the page you designated as your homepage.


    Hi, everyone,

    Thank you for your help. Within function-set-avia-frontend.php, I have the following listed:

    $output .= ($paged == $i)? “<span class=’current’>”.$i.”</span>”:”“.$i.”“;

    Additionally, what you suggested between Line 571, and what to change it to, is the same.

    I appreciate any help offered and would love to move forward in the near future. Thank you in advance for clarification/other ideas.



    Ah ha, I see now that my previous post, and perhaps fabcom’s is automatically altered when posting on this site to “.$1.””;

    What I actually wrote, after </span>, was (within a href), get_pagenum_link($i)

    I’m unaware of what to change this to.


    Hi crkasprzyk,

    I believe Kriesi will be resolving this in his next update if you can hold off until then.




    Thanks for the update. I am in the same situation as fabcom where there have been some mods done to the theme (with the help of support) so would like instructions to just fix this issue if at all possible when the update is released. I don’t want to overwrite anything I don’t have to if there is a way. Thanks a lot.


    Hi torndownunit,

    Just make sure to backup your files and database before updating. :)




    I’m having the same issue. Can you explain how to save your settings and customization and update the theme?


    If you’ve modified any theme files (like the stylesheets or php files) I’d suggest to use a ftp client to overwrite the updated files/folders only. Version.rtf contains a changelog and it will tell you which files were updated. Otherwise, if you didn’t modify any files, you can simply overwrite the theme folder because the dynamic templates, etc. are stored in the database.


    Just to clarify, this update hasn’t been released yet? I didn’t see it on Themeforest, but some of these posts make it sound like it was already released.



    Propulsion, Angular, Coherence and Choices were updated this week, some other themes will follow next week.

    Best regards,



    I know Kriesi had mentioned an update this week, a week ago. I need to move forward, cannot without this one fix, and know I’m not alone. It’s one of many great looking themes for which you guys are associated and I appreciate your time and efforts. Thanks so much for your understanding.

Viewing 30 posts - 1 through 30 (of 46 total)

The topic ‘Portfolio pagination not working.’ is closed to new replies.