Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #4649

    Hi Guys.

    Once updated to version WP 3.1.3 the portfolio single page view stoped working.

    It gives err. 404 no posts found.

    I have posts in my portfolio and I can see the list in my all posts view but I cannot open

    single item from portfolio.

    I red all topics I could found.

    – downloaded the new theme <still not working>

    – changed the portfolio.php as you recommend here: (Purchase code hidden if logged out)(Purchase code hidden if logged out) -fix

    – tried on old theme to edit portfolio.php

    and all other combinations like trying to flush the permalinks… still no result.

    I still have the same mistake

    Please advice

    thanx in advance


    I am having this identical issue. Any help would be appreciated. (I also see that the demo here appears to be having the same issue, as all of the portfolio pages appear to be broken)





    With the introduction of WordPress 3.1, the Custom Post Type section was modified so that a CPT can’t have the same name as a category, page or post – if this happens you get a 404 error.

    Please check if you have a page / post or category with the name “portfolio”, if you do rename or remove it (if it goes to trash you must also empty trash) then resave your permalink structure which will hopefully flush the rewrite rules and fix this issue.



    Hi James.

    Thanx for the advice.

    i want to use as permalink custom: /%postname%/

    Also I put custom menu: listings for my portfolio which is supose to show properties in this case

    then I point in habitat setings that portfolio should be displayed in page <listings> and for this page

    I setup permalink <listings>

    Once I put some post in portfolio it permalink goes: domainname/porfolio/postname not ../listings/postname

    and gives 404 error

    I tried to switch to default permalink: domainname//?p=123 and porfolio works but I wanted to use /%postname%/ for better SEO purposes.. and I still cannot figure why it is not working this way…

    Also I wanna ask: can you advice me what to edit so the background image I choose to appear instead of upgrading the whole theme

    because I made some edits which I prefare not to do again

    Thanx for your quick help


    Can you post a link to the website please. Maybe a page name conflicts with the portfolio slug or your theme version is outdated.


    Hi Dude

    this is the work in progress:

    I used: Habitat 1.0 but I downloaded the lates version: 1.1.1 and the problem still exist qhwn I switch to it…

    I wanted to stick to 1.0 cuz I did some color changes and small tweaks some time ago and because of the

    fact I am not so deep into coding… I fear I might have trouble doing again (in time manner)

    So if portfolio works fine with version 1.0 and I can fix the background image which is now gone I can

    work with 1.0


    Please switch to 1.1.1 and go to Settings > Permalinks and click on “Save”. This should fix the problem.

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Portfolio Issue: 404 error’ is closed to new replies.