Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #1061142

    Making a new post as directed –

    I’m getting a white screen, and in the backend Propulsion gives this error.

    Error thrown

    Function name must be a string

    Edit: I found the compat.php file in another thread, but it doesn’t fix the issue on my site.

    Please let me know the details of the fix, so I can document it for future.

    Thanks!

    #1062235

    Hey gensd,

    The theme is quite old and is no longer available on themeforest. It also doesn’t support later versions of PHP. Please downgrade to PHP 5.6.

    Sorry for the lack of support, we have decided to focus on our more popular themes like Enfold. Maybe that would be a theme for you to consider? There is, unfortunately, no automatic migration available, so you would have rebuild your site from the ground up. Though the Layout Builder in Enfold makes that work pretty easy in my opinion.

    Best regards,
    Victoria

    #1062368

    I know it’s old, but I did see that someone in November was able to get it fixed. My client doesn’t have the budget to rebuild the whole site right now. Is there a way for you to modify the compat.php file to make this work?

    #1062871

    The hosting account that they have with Network Solutions will not allow a PHP downgrade to 5.6, that’s the first thing I tried when troubleshooting.

    #1063736

    Can I get a response please? I need to get this resolved, and as I mentioned, the client doesn’t have resources to rebuild the site right now.

    Thanks!

    #1064183

    Hi,

    Do you have any closer information about the error – an error log with the file and line number and the context the error occured would be helpful.

    Best regards,
    Günter

    #1064298

    Where would this error log be?

    #1064574

    Hi,

    Best to contact your hoster how you can access the php error log. I’m not a system admin but it might me necessary to activate some server settings.

    Best regards,
    Günter

    #1064761

    I’ve set it up to track php errors, but nothing has updated the file yet. Is the white screen something that would throw an error?

    #1064929

    Hi,

    As you said in your first reply: Error thrown: Function name must be a string

    This should be written to the error log. Did you get any closer info than that?

    I tried to login but I need a WP admin account.

    What php version WP verion and what theme version are you using?

    Best regards,
    Günter

    #1064973

    I’ve made an admin login for you.
    The site is using PHP 7 .. WP 5.0.3 .. Propulsion theme 2.8

    The error is thrown when I try to access the Propulsion theme settings. Otherwise it just displays white pages on the site.

    #1065126

    Hi,

    Version 2.8 is from 2015 April 29th – this is not compatible with PHP 7.

    Please see private content below.

    Best regards,
    Günter

    • This reply was modified 4 months ago by  Günter.
    #1065190

    Thank you!

    • This reply was modified 4 months, 1 week ago by  gensd.
    • This reply was modified 4 months, 1 week ago by  gensd.
    #1065393

    Hi,

    Glad I could help you.

    Have a nice day.

    Best regards,
    Günter

Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘PHP 7.2 issues with white screen’ is closed to new replies.