Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #20624

    my site loads fine but when I click any page or link I get this message:

    Parse error: syntax error, unexpected ‘?’ in /home/skinney1/public_html/designtexsi/wp-content/themes/newscast/functions.php on line 97

    I looked at line 97 but can not figure out what needs to be changed or updated. I compared the code in the functions.php on the server with the back up copy I have and they match – so nothing has changed but I’m getting this error.

    Any help?

    I was running 3.4.1 and manually upgraded to wp 3.5 thinking that would work – but no luck.



    Please post your functions.php code. Use a service like. https://gist.github.com/




    Strange, the file doesn’t contain any syntax errors. You can try to re-upload/re-install all theme files. Make a backup of the newscast folder, re-upload all files and then replace the php files one by one to find the file which contains the syntax error.


    Wow- that’s a long process to find a simple problem. Have you dealt with this issue before?



    I am not sure about the complexity level of the problem but it looks like you rewrote practically the entire theme inside a frameset. so its definately not something I’ve seen yet. But no worries, we will get to the bottom of this.

    Would you put file /framework/include_framework.php on gist also.

    Please test something. After you put the file up. copy the entire contents of /framework/include_framework.php and paste it all in functions.php after line 97. Please comment out line 97 so that it will look like the code below after you pasted everything after it.


    Actually before you do any of that, could you delete everything below line 95, your last line. I am not sure what you have below it but those aren’t lines. My new fresh theme has lines 95-97 as proper lines


    while you are missing 96 and 97 entirely so you empty space is not quite empty. I think we may have some paranormal activity on those two ghost lines.

    Take a look. http://i.imgur.com/EzldbW7.png Yours is the left one. The only differences are the missing rn on 96 and 97 and that strange colored area.

    Can you copy 95-97 from what i pasted above over your lines first and see if anything changes.




    I tried to replace the code as describe above to match the NEW (not evil) php file and still have the same issues.

    here is is the framework code you requested I post: https://gist.github.com/eastofnyc/5048363


    I pasted the includes framework php as your described above and still received the same error.

    Could this be a missing wordpress database issue?



    If by manually upgrade you mean that you deleted the wp-admin and wp-includes folders and then deleted every file in your root folder except wp-config.php and the wp-content folder and then uploaded all the files via ftp , you’ve done it correctly. However just in case try doing it again.

    When you pasted the contents of include_framework.php into functions.php , the error now would be inside functions.php on the same line as before which now is an empty space or ##### ?

    Because I am wondering if those perl style comments with hashes are causing a problem.

    Please try this file, its a combination of the two files and i changed the line numbers around a little so you should definately not get an error on the same line number now. Please let us know

    http://pastebin.com/QWVd196K ..at line 103 starts the include_framework.php


    also you are using http://designtexsi.com/designtexsi/ and http://www.surfaceimaging.designtex.com/ … are you calling the correct pages into your frameset?




    Still no luck. Still having the same error message on line 97 of functions.php



    You mean you replaced the code and are having an error on line 97 with the new functions.php file i gave you ? what do you see on your line 97?

    This should be your line 97 now


    Please set me up a temp admin account and email me at usjahm (at) gmail (dot) com.. If it is really the case that you are getting an error on the same line no matter what code is on that line, then your code is haunted :)




    proof is in the pudding.


    I’ll figure out how to grant you admin access to the host. WordPress is not letting me in at all – can not access wp-admin.php



    I await a working login/pw to fix it up.



Viewing 13 posts - 1 through 13 (of 13 total)

The topic ‘Parse Error’ is closed to new replies.