Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
  • #26610

    Hi there,

    I’ve been using Velvet theme for more than a year and I’m very happy with it, but I’ve noticed a bug just today with the blogroll’s pagination on homepage.

    When you go on page 6 it’s allright :

    But starting frome page 7 it doesn’t work anymore :

    I’ve tried to change the category displayed and the number of posts per page, to see if it had something to do with the displayed posts. But it doesn’t matter if I have 14 or 9 pages, the posts are all displayed until page 7, and then nothing…

    The category’s archives are working fine but none of them has more than 2 pages to show…

    Any idea where the problem might be ?

    I’m using velvet’s version 1.1.5…

    Thanks for your help !



    My suggestion, and I am no salesman, is for you to upgrade to Enfold theme ( ) which is Kriesi’s latest which uses the latest version of the Avia framework which he rewrote completely. There is no way to make it backward compatible with the Velvet theme, however the beauty of Enfold is that you can make any website with it – it has a visual drag and drop page builder which allows you to create any look by moving around page elements to create stunning looks with no need to know code.

    Enfold is also responsive, so it will look great on large monitors, tablets and mobile devices which now account for 50% of website visitors. Just shrink your browser window to the size of a iPhone or iPad and compare how Velvet and Enfold will look to a mobile visitor. All the features are listed on Themeforest (disclosure: affiliate link).

    Your pagination looks strange. Is this how it normally looks to you with those little symbols?




    Thanks Nick,

    unfortunately it’s really not an option for us. We have 2 blogs running under velvet and it would take too much time to switch to an other theme right know (we are currently working on our website and it’s our top priority rather than our blogs).

    Enfold seems beautiful I agree, and we may consider it next year… but at the moment I just want Velvet to work as it’s supposed to :-)

    The pagination you showed is really weird indeed, here is what I see in my browser :

    What could explain that difference ? Could it have something to do with the 404 error ?



    No problem, i understand.

    Lets take a look at

    1) Settings > Reading. The settings look like this yes?

    2) In Velvet > Theme Options. What do you have set as the home page? how about the blog page, is it set there as well?

    Are they both set to the same page – the home page?

    3a ) In that case just chose Select from the dropdown for the blog and instead add a Blog Element to the Dynamic template for the homepage and make sure you set pagination on that element as shown in last url.


    3b) If however the Blog is not set in Enfold > Theme Options, then set it to the home page.




    Sorry for the delay, and thanks for your answer.

    Question 1 : yes it is

    Question 2 : Both are set on the same page (homepage, named “Accueil”), which uses a custom template called “homepage blogroll”…

    So question 3 a : it is already set this way, have a look :

    and b : it is already set to the home page

    So everything looks fine on this side…


    Hi efh,

    I’m going to tag the topic for Kriesi as I’m not sure what the issue could be looking at the theme code and seeing the issue live. I’ve seen something similar some time ago on another theme but it was related to a plugin which was causing an issue with the number of posts to display on the queries.

    So you could try disabling any active plugins you have and then re-setting the various theme and wordpress options to try and refresh all the settings.




    Hi Devin,

    thanks for your message. I did what you asked, very carrefully.

    First I disabled all of the plugins, and the bug remained. I re-enabled them one by one.

    Then I tried to disable the plugins one by one.

    Still no change with my issue.

    By the way I don’t have that much plugins installed :

    – Google Analytics for WordPress

    – AddThis Social Bookmarking Widget

    – BackupBuddy

    – Broken Link Checker

    – Edit Flow

    – Simple Image Sizes

    – Subscribe2

    All are up to date except Subscribe (which will be replaced very soon with an other one).

    I really don’t get what is so mysterious about the number 7 that the blogroll goes 404 from this page.

    And the screenshot that Nick took is weird too…

    So I tried an experiment on an other blog (same theme but different pugins).

    Same settings (blogroll on homepage) than presentation-experts, I get the same error, but starting from page 15 instead of 7 this time :

    But if I set a blogroll on an other page it works fine : for exemple here is the final page with the oldest post :

    I tried to do the same on the first blog (except this time I just applied the homepage’s template instead of creating a new one) :

    I didn’t change any of WordPress’ reading options or Velvet’s options during this tests.

    Does it help ?…



    Yes. Those plugins do look pretty harmless except the Edit Flow that I am not familiar with. But in any case, I read over your response and I think my directions were crappy, so let me rephrase.

    Test 1) Homepage Set / Blog Set … in Velvet > Theme Options.

    Test 2) Homepage Set / Blog *not* set … in Velvet > Theme Options

    Test 3) Homepage Set / Blog Set *to any other page except the homepage*

    Test 4) Create new dynamic template with ‘blog element’ alone and add this template to a test page (*do not designate* this page as blog in Enfold > Theme Options) and see if pagination working.

    Test 5) Create new dynamic template with ‘blog element’ alone and add this template to a test page (*designate* this page as blog in Velvet>theme options) and see if pagination working.




    Hi Nick,

    I’m sorry, maybe my response was not clear because, as you noticed, english is not my native language.

    Edit flow is just a backoffice plugin that helps you organize the publication flow when you have multiple authors.

    test 1) (previous configuration), 2) and 3) made no difference.

    Current configuration is 3) since I left the options set as in test 5).

    Test 4)

    is working (new template)

    Test 5)

    is also working (new template)

    Looks like the only issue is with the homepage…

    Thanks a lot for your help,



    Your language is just fine. Sorry for the delay in responding.

    So now, if you take first test 4, and then test 5, and make first the page in test 4, and then the page in test 5, as the home page. Does pagination that worked, automatically break? Because I am not finding this issue on my local install.

    Could you make an account for me to look at your setup if you have a development environment, my email is usjahm (at) gmail (dot) com. But please do try the two above suggestions first.




    Hi Nick,

    I tried making “test 4” and “test 5” homepage using Velvet’s options.

    And it doesn’t work either this way.

    So I tried to switch the WP Reading setting “Frint page displays” > Page test 4 or test 5 as well.

    In that case, the pagination just doesn’t work : when clicking on one number, the URL changes but not the displayed posts.

    Unfortunately I don’t have a development environnement anymore for this blog, but I could create you a WP and FTP account if you wish so.

    Thanks for your help.



    Please update your theme. You are using Velvet 1.1.5 while the current version is Velvet 1.4. You can download the update by loging into . The update will overwrite every single theme file and will need to get installed via ftp. Please make a backup first.




    This will need some work since I had to edit a few files within the theme (ie to get an other size of featured image). Will do that when I come back from hollidays, and tell you what happen then.



    Sounds good. Look forward to hearing that all is well.




    Hi Nick,

    I did the update and the problem seems to be solved :

    I took me some time since I had to translate every “frontend” strings in french and do some small adjustement from here to there ;-)

    The only issue I noticed is that the blogroll is now showing the content (until “More”) instead of the excerpt as it used to do.

    I find this anoying since I like to have an excerpt that sums the post up a bit more than first sentences do…

    I can’t figure out where to change that, should I do something on loop-index.php, line 85 ? It looks like there is a function about it in function-set-avia-frontend.php on line 886 but I don’t want to mess with anything here…

    Thanks for your time and patience,


    In your theme files open includes>loop-index.php and look for:

    the_content(__('Read more →','avia_framework')); ?>

    on line 85 just as you though. Changing that to:

    the_excerpt(__('Read more →','avia_framework')); ?>

    Should do it.



Viewing 16 posts - 1 through 16 (of 16 total)

The topic ‘Pagination ot working for blogroll homepage’ is closed to new replies.