Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #20668

    I have purchased the incarnation theme for my church. I want to know how to add pagination to pages not posts and what is the shortcode for this?



    Please give an example of a paginated page – a blog page or a category page you mean being paginated? Because pages are indexes for groups of posts thus they have pagination on the pages but its posts that are being counted (like news articles, blog posts, portfolio items, sermons, events).

    Perhaps if you would explain what you are trying to do, I can tell you how to go about creating it. But there is no shortcode for what you are asking. Example: You want to create a page that shows 3 blog post summaries on each page and since there are 9 posts in total you will need 3 pages (paginated). You would go to Incarnation > Template Builder. Add a new dynamic template , calling it test-blog for example, and then add to it a blog element, where you set the number of posts on each of the pages. Please look at the image that illustrates this

    After you saved the template, you add a new page and you attach the dynamic template that you’ve just made to it as shown here Then after you save the pagination will automatically appear where it is supposed to based on the setting you chose in the dynamic template.




    If I have a page where the content is really long and I want to divide that content into other pages using the pagination process. I know if you add a next-page tag on the Twenty-twelve theme it will create the pagination.


    Hi vcci,

    Since the theme doesn’t have it included, you’ll need to add:

    <?php wp_link_pages(); ?>

    Open up the theme files and go to includes>loop-page.php. Within the file look for:

    //display the actual post content
    the_content(__('Read more','avia_framework').'<span class="more-link-arrow"> &rarr;</span>');

    one line down, add:


    You can style it or dress it up using:




    Thanks for your help I used the code above and everything seems to be working except the number of the selected page is showing up in the wrong place. Here is a link to show you what I’m referring to

    Thanks for your help


    Try adding the following CSS to your Quick CSS (located under the Styling Tab in the theme options) or the custom.css file in the css folder of your theme files:

    #page-links a {
    display: inline-block;
    float: none;
    border: none;
    font-size: 16px;

    That should clean it up a bit since its just using the default output. You can also re-style it with the code options in the link above (to the codex entry on wp_link_pages).



Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Pagination on Pages not Post’ is closed to new replies.