Viewing 30 posts - 1 through 30 (of 31 total)
  • Author
    Posts
  • #775750

    Hello to our lovely support staff,

    As you know, the Layer Slider issue has popped up again after the 4.0.5 Enfold update. Many people hove posted this on the original thread “Please read – Regarding Wordfence LayerSlider warning on Enfold 4.0.3 “, but it has been very noticeable that the support staff has not commented on the re-ocurrence. This is somewhat troublesome, as you are most often very forth coming and willing to explain and share your findings.

    Can you comment on what is happening and how long until the next update that will take care of this matter so it does not resurface?

    Can you tell us if this issue is a potential security issue? If the Layer Slider is not being used, is this an urgent issue? The Wordfence plugin reports this as a “critical” error; but disabling the Wordfence plugin is not an option as it is one of the best security plugins available.

    Any and all information would be appreciated.

    Thank your for your tireless dedication to helping Enfold remain as one of the best WP Themes available!

    #775966

    Hey jancecile,

    There has been another Layer Slider update, that’s why you are seeing that warning. If you do not use Layer Slider you can deactivate it. (Purchase code hidden if logged out)(Purchase code hidden if logged out) -0-4-update/#post-770572″>Here is how you can do it.

    Thank you for using Enfold :)
    If you need further assistance please let us know.

    Best regards,
    Victoria

    #776153

    Hi Victoria,

    Yes, I know there was another LS update. And yes, thank you for the work arounds that “should be able to” fix it.

    My question is still — is there an Enfold update in process that will actually address this issue? If so, what is the ETA?

    Are there plans to have LS be a separate plugin that is not embedded in the theme? I do use some of the Enfold sliders on my pages, and I do not want to disable LS because I am not certain that doing this may mess further with my sites.

    Thank you

    #776180

    Hi jancecile,

    Layer Slider can be used as a separate plugin, it costs $20 that way and can be updates any time an update is available, disabling Layer Slider is safe :) It’s just a set of files and functions that will not be called and used.

    If you need further assistance please let us know.
    Best regards,
    Victoria

    #776402

    Hi Victoria,

    Basically, I would just like to have the Enfold theme updated and the Layer Slider plugin update removed. I’d like to go back to where we all were before this update issue became a problem.

    Is this going to happen?

    Thanks,

    #776552

    Hi Victoria, Layer-Slider is blocking me from accessing wp-admin. Failure-Alert: <Parse error: syntax error, unexpected T_FUNCTION in /kunden/328876_8001/web/1680744/A1680744/umshaus.ch/wp-content/themes/enfold/config-layerslider/LayerSlider/layerslider.php on line 109>

    Could you pls gimme some insight on how to fix this using ftp?

    Thank you, Christoph.

    #777284

    Hi czum,

    You should be able to disable the LayerSlider if you add this your child theme’s functions.php file:

    
    add_theme_support('deactivate_layerslider');
    

    You can edit it via FTP, if no child theme – put in Enfold’s functions.php after

    if(isset($avia_config['use_child_theme_functions_only'])) return;

    .

    Let us know if this was helpful.
    Best regards,
    Victoria

    #777383

    Thanks a lot, Victoria. Working fine. wp-admin is back and accessible. Happy Time, Christoph.

    #777384

    Hey!

    Happy you got it short out.
    We will do have an update soon again and we appreaciate all of your patience.

    Thank you very much

    Best regards,
    Basilis

    #778082

    Question re: the Layer Slider issue… does Enfold need Layer Slider to allow Avia media options to work? That’s where my sliders are developed.

    Thanks

    #778382

    Hi,

    If you are using Layer Slider that came bundled with enfold, yes you need the Layer Slider to show the slides that were created using the built-in plugin.

    if you deactivated the built-in plugin and use the Layer Slider as a separate plugin then you need to recreate the slides.

    Best regards,
    Vinay

    #778488

    Thanks Vinay — so, the Layer Slider is the basis for any sliders that I use within the Enfold theme “media options”?
    When is the next Enfold update coming?
    Thank you!

    #778586

    Hi!
    Sorry for the confusion,

    1. If you create a slider from Dashboard > Layer Slider you can insert that slider from advanced layout builder > media element.
    2. Any other slider like Full-width slider or Easy Slider is not related to layer slider.

    We do not have an ETA for the next update but we release updates quite often.

    Regards,
    Vinay

    #780250

    Hope the update comes sooner than later!
    Thanks!

    #792423

    I am very tired seeing these warnings. Of course, applied your fix @victoria_d but doesn’t seem to fix. Using the line of code in my child theme functions file:

    add_theme_support('deactivate_layerslider');

    Here’s my various issues:
    2017-05-12 10:53:52.135 [NOTICE] [##.##.##.###:HTTP2-15] [STDERR] PHP Warning: fclose() expects parameter 1 to be resource, boolean given in /wp-includes/functions.php on line 4790
    2017-05-12 10:53:52.135 [NOTICE] [##.##.##.###:HTTP2-15] [STDERR] PHP Warning: fread() expects parameter 1 to be resource, boolean given in /wp-includes/functions.php on line 4787
    2017-05-12 10:53:52.134 [NOTICE] [##.##.##.###:HTTP2-15] [STDERR] PHP Warning: fopen(/wp-content/themes/enfold/config-layerslider/LayerSlider/layerslider.php): failed to open stream: No such file or directory in /wp-includes/functions.php on line 47

    As I’ve shared before, it’s time to stop embedding and bloating your codebase with these applications. It’s like chasing a rabit’s tail with support this year for this one application. Highly considering another theme altogether. It’s like Enfold has run it’s course. Perhaps time to produce Enfold LIGHT or FULL. I don’t want layerslider for example… And the new v4 seems like a naming convention only. Was hoping for more effort.

    Dave

    #792895

    Hi Dave,

    Sorry to hear about that. Having two versions of Enfold might be a good idea. If Layer Slider is not used it does not get called and the notices are not supposed to be there. Do you mind if we take a closer look? If yes, can you give us temporary admin access to your website in the private content box below, so that we can have a closer look.

    I think it’s a very harsh speculation, to say that “Enfold has run it’s course” just because you have a few notices in your logs, and not major errors or performance issues. At the end of the day, your website is working and serving your business.

    If you need further assistance please let us know.
    Best regards,
    Victoria

    • This reply was modified 7 months ago by  Victoria.
    #821089

    Dear all,

    with the latest update of Enfold, I have again an issue with Layerslider. umshaus.ch is showing the following failure-alert: Fatal error: Declaration of avia_sc_comments_list::shortcode_handler() must be compatible with that of aviaShortcodeTemplate::shortcode_handler() in /kunden/328876_8001/web/1680744/A1680744/umshaus.ch/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/comments.php on line 14

    I have checked your mentioned recommendation and uploaded functions.php as proposed above. Did not help. Can you pls get back to me with a proper solution? Thank you, Christoph.

    #821242

    Hi czum,

    Could you please try to reinstall the theme via FTP? Are you able to access dashboard?

    Best regards,
    Victoria

    #821244

    Hi all,
    have the same trouble, same error everytime I try to install Enfold Theme via WordPress (4.7.5)

    “Fatal error: Declaration of avia_sc_comments_list::shortcode_handler() must be compatible with that of aviaShortcodeTemplate::shortcode_handler() in /wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/comments.php on line 14”

    Any idea what couse the problem?

    #821698

    Hi elzevir,

    Same questions: Could you please try to reinstall the theme via FTP? Are you able to access dashboard?
    Which version of php are you running?

    Best regards,
    Victoria

    #822446

    Hi Victoria, I reinstalled enfold using FTP. installation worked fine but my page is still blocked: http://www.umshaus.ch – Can you pls help me out here? Thanks, Christoph.

    #822768

    Hi czum,

    You need to ask your provider to update to minimum php 7
    https://kriesi.at/support/topic/ (Purchase code hidden if logged out)(Purchase code hidden if logged out) -update/

    Best regards,
    Victoria

    #823309

    Hi Victoria, I checked with the provider. Hosting is at PHP 7.1.6 and APACHE at 2.4.25 – so technically all set. Do you have some hack to disable Layerslider via FTP in order to reach my Dashboard again? Thanks, Christoph.

    #823858

    Hi czum,

    Please try adding this to the bottom of your functions.php file:

    add_theme_support('deactivate_layerslider');

    Best regards,
    Rikard

    #824001

    Hi Rikard, thanks for your comment. I did as mentioned. Cannot get thru to my page. Keep getting the following error:

    Fatal error: Declaration of avia_sc_comments_list::shortcode_handler() must be compatible with that of aviaShortcodeTemplate::shortcode_handler() in /kunden/328876_8001/web/1680744/A1680744/umshaus.ch/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/comments.php on line 14

    Can you please assist? Thanks a lot, Christoph.

    #824373

    Hi Christoph,

    Ok, thanks for the feedback. Did you add the code I posted to your functions.php file via FTP and did that not work? If not then could you please open a new thread and include FTP and WordPress login details in private please?

    Best regards,
    Rikard

    #824414
    This reply has been marked as private.
    #828750

    Hi,

    If you turn WP_DEBUG off, does it hide the issue and the site is working properly, or you still have problems?

    Best regards,
    Basilis

    #828915

    Hi,
    I reinstalled enfold via ftp, I disabled Layerslider as mentioned here: http://kriesi.at/documentation/enfold/deactivate-the-layerslider-plugin/ – and then I turned WP_DEBUG off.

    Result: Not working. Failure-Message: Fatal error: Declaration of avia_sc_comments_list::shortcode_handler() must be compatible with that of aviaShortcodeTemplate::shortcode_handler() in /kunden/328876_8001/web/1680744/A1680744/umshaus.ch/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/comments.php on line 14

    Can you pls help out?

    Thanks a lot, Christoph.

    #829299

    Hi!

    Please contact your hosting provider and ask them to upgrade your PHP version, preferably to PHP 7 and minimum 5.6. That should solve the issue.

    Regards,
    Yigit

    • This reply was modified 4 months, 3 weeks ago by  Yigit.
Viewing 30 posts - 1 through 30 (of 31 total)

You must be logged in to reply to this topic.