Tagged: , ,

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #8506

    Hi Guys,

    I just installed Anuglar and love it so far. I am having some trouble with the oEmbed however.

    I’ve imported the dummy content, and attempted to add a vimeo video one of the portfolio items (Flashlight) and the video is simply displaying the URL.

    I can provide admin access to the control panel if you would like.

    Here is the site: http://roadtripfilms-v2.ragingartists.com

    I have made sure the auto Embed is enabled in WordPress Settings >Media.

    Thank you for your time, Cheers!


    I was able to post the same video, to another wordpress blog hosted on the same server.

    This is a self hosted server so we have control of the full stack/OS. All WP installations on this server are carried out via a custom deploy script, so both blogs are using exactly the same underlying infrastructure.

    I still cannot get the WP installation using Angular to embed videos via oEmbed in posts or portfolio items.

    Nothing in the Apache or php-fpm logs as well.


    Looks like embedding using the URL alone, or [embed] tags is not working on this blog using the default WordPress theme either.

    Could this be a problem with wordpress 3.3.1 itself?


    I tried re-installing using 3.2.1 (the blog I was able to embed a video on using oEmbed was on this version) and this had no affect on oEmbed.

    It almost seems like the AJAX is giving up too soon, before the video is placed?

    I am stumped. In conclusion, so far I have eliminated:

    – Problem with PHP

    – Problem with Apache

    – Problem with conflicting plugin (no other plugins installed)

    – Problem with WordPress Version (tried 3.3.1 and 3.2.1)

    – Have searched the web for hours, verified the vimeo code is correct in wp-includes/class-oembed.php

    What else can we check??


    I verified sockets are enabled on a phpinfo page:

    ‘./configure’ ‘–build=x86_64-redhat-linux-gnu’ ‘–host=x86_64-redhat-linux-gnu’ ‘–program-prefix=’ ‘–prefix=/usr’ ‘–exec-prefix=/usr’ ‘–bindir=/usr/bin’ ‘–sbindir=/usr/sbin’ ‘–sysconfdir=/etc’ ‘–datadir=/usr/share’ ‘–includedir=/usr/include’ ‘–libdir=/usr/lib64’ ‘–libexecdir=/usr/libexec’ ‘–localstatedir=/var’ ‘–sharedstatedir=/usr/com’ ‘–mandir=/usr/share/man’ ‘–infodir=/usr/share/info’ ‘–target=x86_64-redhat-linux-gnu’ ‘–cache-file=../config.cache’ ‘–with-libdir=lib64’ ‘–with-config-file-path=/etc’ ‘– (Purchase code hidden if logged out) =/etc/php.d’ ‘–with-mysql-sock=/var/run/mysqld/mysqld.sock’ ‘–disable-debug’ ‘–with-pic’ ‘–disable-rpath’ ‘–with-bz2’ ‘–with-exec-dir=/usr/bin’ ‘–with-freetype-dir=/usr’ ‘–with-png-dir=/usr’ ‘–with-xpm-dir=/usr’ ‘–enable-gd-native-ttf’ ‘–without-gdbm’ ‘–with-gettext’ ‘–with-gmp’ ‘–with-iconv’ ‘–with-jpeg-dir=/usr’ ‘–with-openssl’ ‘–with-pcre-regex=/usr’ ‘–with-zlib’ ‘–with-layout=GNU’ ‘–enable-exif’ ‘–enable-ftp’ ‘–enable-magic-quotes’ ‘–enable-sockets’ ‘–enable-sysvsem’ ‘–enable-sysvshm’ ‘–enable-sysvmsg’ ‘–with-kerberos’ ‘–enable-ucd-snmp-hack’ ‘–enable-shmop’ ‘–enable-calendar’ ‘–without-sqlite’ ‘–with-libxml-dir=/usr’ ‘–enable-xml’ ‘–with-pear=/usr/lib64/php’ ‘–enable-fpm’ ‘–without-mysql’ ‘–without-gd’ ‘–disable-dom’ ‘–disable-dba’ ‘–without-unixODBC’ ‘–disable-pdo’ ‘–disable-xmlreader’ ‘–disable-xmlwriter’ ‘–without-sqlite3’ ‘–disable-phar’ ‘–disable-fileinfo’ ‘–disable-json’ ‘–without-pspell’ ‘–disable-wddx’ ‘–without-curl’ ‘–disable-posix’ ‘–disable-suhosin’ ‘–disable-sysvmsg’ ‘–disable-sysvshm’ ‘–disable-sysvsem’ ‘–without-mcrypt’



    Please create me a wp admin account and send me the login data to: (Email address hidden if logged out) – I’ll look into it. If I can’t find a solution I’ll forward the issue to Kriesi


    Just sent the login credentials – Thanks for your time dude!


    Great – I’ll look into it asap.

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘oEmbed not working’ is closed to new replies.