Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
  • #8800


    First of all thank you for a wonderful theme. I have two questions:

    1) Today I updated woocommerce to 1.4, and right after the update the product slideshow on the front page stopped working. It now displays the message “No Products found which match your selection”. It was working fine before and all my products are marked as in stock, with many items in stock. I have also tried making them featured, as well as adding new categories to no avail. I have double checked and have multiple product categories selected.

    2) How do I change the top right “search site” box to woocommerce’s search products widget?

    Thank you in advance.




    1) This is a bug with WooCommerce 1.4 – I’ve reported it to Kriesi.

    2) Open up searchform.php and replace:

    <form action="<?php echo home_url( '/' ); ?>" id="searchform" method="get">
    <input type="submit" value="" id="searchsubmit" class="button"/>
    <input type="text" id="s" name="s" value="search site"/>
    </form><!-- end searchform-->


    <form role="search" method="get" id="searchform" action="<?php echo esc_url( home_url() ); ?>">
    <label class="screen-reader-text" for="s"><?php _e('Search for:', 'woocommerce'); ?></label>
    <input type="text" value="<?php the_search_query(); ?>" name="s" id="s" placeholder="<?php _e('Search for products', 'woocommerce'); ?>" />
    <input type="submit" class="button" id="searchsubmit" value="<?php _e('Search', 'woocommerce'); ?>" />
    <input type="hidden" name="post_type" value="product" />


    Hi, I followed directions exactly and changed the searform.php file, but the result is still the same and still not displaying products.


    It maybe a problem with WooCommerce 1.4 and the search query. I’ll ask Kriesi.


    Ok, thanks a lot. I’ll keep checking back to this thread.



    Sorry for the delay, I was on vacation last week and returned just a few hours ago. Been working non stop to resolve any woocommerce related issues since then and I am making good progress. A theme update which fixes the problem is already in the queue, it will be available within the next hours once approved by themeforest.

    However I have noticed a similar problem with my demo sites that I was only be able to solve by re-saving the products. I just had to open them in the backend and hit the save button. Seems woothemes modified the query that pulls the products so it might be necessary for you to do this as well…

    Best regards



    Hi Kriesi,

    Hope you are doing well. My Store run well with woo-commerce 1.3.2. when upgraded into woo-commerce 1.4.1, some functionality loosed. i have received the error message like

    “No products found which match your selection.”

    you can see the problem here.

    help to to get my site back.




    I’m having the same issue. I will check back to later to see if a fix has been issued. My site is still under construction so it’s not a big deal yet. But if the issue is not resolved soon, I think I will try to apply the older version.


    it seems a lot of people are having this problem, and have for a few days. need a fix asap, please!


    Me too not even my Product Slider is working!!!!!!! Ahhhhhhhhhhhhhh


    The fix is available. Here is a link to where I posted how to fix.

    Good Luck Everyone!

    Thanks Kriesi for getting on top of the fix right after vacation. :-)


    Fantastic its working now we’re in business! Thanks!


    Ok so I thought it was all fixed until I started added some new product. The pricing is now missing from the simple product page. Anyone, noticed this yet? We need a fixed for this now.

    Kriesi, any ideas.

Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘"No products found which match your selection" and "Search Site" question’ is closed to new replies.