Viewing 23 posts - 1 through 23 (of 23 total)
  • Author
    Posts
  • #848355

    For several months now, when I create a New Product, select the proper categories, and do ALL the things I did before, the newly created product do not show in any of the shop or category pages.

    I have used all the old product creations by editing them to the new products, but alas, I have run out of old products.

    Please help.

    P.S. If you search for the new product recently created, it will show up in the search. You can also click on the link on the product creation page and the product will show up, but not anywhere else.

    This link is an example of a newly created product that does not show up anywhere: http://www.cabinbright.com/product/ (Purchase code hidden if logged out) -for-ceiling-fixture/

    #849043

    Hey brignolo,

    Thanks for providing the login, I have check your latest product and I can see it in categories and some pages you created (I have posted the links in private content)

    Best regards,
    Nikko

    #849657

    Yes, I understand that. What I cannot do is see that newly created product on the page called for on the menu: http://www.cabinbright.com/ (Purchase code hidden if logged out) -bulbs/

    #850293

    Hi,

    Please create a backup of the database and the whole site then install the following plugin.

    // https://wordpress.org/plugins/wp-sweep/

    Clean the database and clear the transients.

    Best regards,
    Ismael

    #1026942

    This did not work. Any new product will not show up where it is supposed to.

    #1027379

    Hi,

    It’s been a while. Are you trying to include the newly created products in the menu? Have you tried adding the product manually in the Appearance > Menus panel?

    Best regards,
    Ismael

    #1027643

    Hi Ismael,
    I’m trying to get the newly created products to show up on the pages checked for the Product catagories. The pages I have setup for those new products do not show the newly created products. If I edit an old product, no longer in my inventory, to the attributes of the new product, it will show up fine in the catagory page.

    #1027655

    Here’s an example:

    I built a product page, NightScapes: https://www.cabinbright.com/wp-admin/post.php?post=7702&action=edit and have checked the Marine Catagory. The product does not appear on the Marine product page: https://www.cabinbright.com/marine/

    If I add it under the Marine menu, it will show up as a child of the main menu dropdown, but that is the only way it will appear. I want it to appear on the main Marine product page: https://www.cabinbright.com/marine/

    It seems like those products created before a certain date will work, but those created after a certain date do not.

    Please help, I have 20 more products I need to put on my website, and will be creating another marine-boat oriented website and want to use Abundance for that as well, but am a little concerned about that right now.

    #1028168

    Ishmael:
    Could you please help me? All my new products I’ve told all my customers about, cannot go to my website to order.
    Please tell me how to get the new product to the products page.

    #1028283

    Hi,

    Thanks for the update. Can you give us access to the file server? I would like to check the theme files.

    Best regards,
    Ismael

    #1028322

    Do you mean my account at Blue Host for the FTP server?

    #1028575
    This reply has been marked as private.
    #1028961

    Ok,

    Here are the login credentials you need. Sorry about the delay, and thank you for your patience.

    Hopefully, we can get this resolved.

    #1029530

    Have you been able to check this out yet?

    #1029774

    Hi,

    I’m sorry for the late response. I modified the includes > helper-templates.php > shop function and altered the product query a bit. The new products are displaying properly now.

    Best regards,
    Ismael

    #1030409

    Thank you Ishmael!

    I don’t know how that happened, but thank you so much for fixing it. Now all I have to do is figure out why my thumbnails on each product page under the gallery photos is fuzzy until you click on it.

    I tried regenerating this thumbnails, but that doesn’t seem to work.

    Again, thank you very much!

    Joe

    #1030691

    >> thumbnails on each product page under the gallery photos is fuzzy until you click on it.

    Having this same issue.

    #1030695

    Fixed blurry thumbnails by adding this to the functions.php file:

    add_filter( ‘woocommerce_get_image_size_gallery_thumbnail’, function( $size ) {
    $size[‘width’] = 300;
    $size[‘height’] = 300;
    $size[‘crop’] = 1;
    return $size;
    }, 10, 1);

    #1030926
    This reply has been marked as private.
    #1031516

    Hi,

    Thanks for the update.

    You can add the filter in the functions.php file.

    add_filter( 'woocommerce_get_image_size_gallery_thumbnail', function( $size ) {
        $size['width'] = 300;
        $size['height'] = 300;
        $size['crop'] = 1;
        return $size;
    }, 10, 1);

    @cryptoart: Thanks for the info.

    Best regards,
    Ismael

    #1032031

    Yes, thank you. Can you please tell me where in the functions.php it goes?

    Thank you,

    Joe

    #1032359

    Hi Joe,

    It should go into the child theme functions.php and there any place after opening php tag.

    Best regards,
    Victoria

    #1035232

    Victoria:

    Thank you for the response. I REALLY looked for where to put that code in my FTP server, but I could not find the functions.php file. I could find it in the website panel, but it would not allow me to save the file in the WordPress (Abundance) files. If I try, it just breaks the site and I have to restore the theme from the back-up. Is it possible to help me with this? The log in info for my FTP server is attached.

    Thank you for your patience,

    Joe.

Viewing 23 posts - 1 through 23 (of 23 total)

You must be logged in to reply to this topic.