Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #15082

    This is a portfolio and the single entries were working fine. Came back recently and discovered the single pages giving me 404.

    Tried everything, its not the permalinks or anything obvious. Haven’t touched the htaccess file, haven’t changed anything related to the portfolio. Tried creating a new template, recreating the whole area. Nothing.

    Any ideas why this may not be working?


    Also, more info

    1. The page “Press” has my dynamic template that I created to host the portfolio

    2. My portfolio slug is “press-item”

    3. even the Preview link doesn’t work

    it was all working before


    Hi indierockmedia,

    Have you installed any plugins or updated wordpress recently? Can you also check to see if your host has modified anything within the server (changed permissions etc).

    When changing your permalinks to default, do the single pages work again?




    Hi, I haven’t upgraded and the same issue happens on MAMP. I disabled all plugins and haven’t changed any permissions and even tried setting permalinks to default. All a no go. I’m just baffled because the portfolio worked fine before, now just doesn’t, and most of the changes ive done since styling the portfolio were just style changes and minor woo commerce plugin changes and adding options to the template builder..


    Ok I just tried the permalinks again. I switched back to default (which was one of the first things I tried, to no avail originally) and the single page worked, but switching it then back to “post name: http://localhost:8888/sample-post/“, caused the 404 page again..


    Try going through the WordPress troubleshooting options here:

    One specific one I would suggest is completely re-creating your .htaccess file.




    ok will try. I recreated the .htaccess file too before I posted here, nothing either. But will check out this list. thanks, any brain storming helps, never know if someone will post something I hadn’t thought of. I even installed a fresh propulsion theme and still didn’t work, leaving me to think it may be something outside of the theme.


    Ok got it to work. I just reset all the settings from scratch one more time. On my local, I was getting errors saying I couldn’t save, but worked fine on the live preview I posted above. Reset everything and now its all working. OMG three days and finally got it! Hope this helps others and thanks for the quick feedback =)


    Strange.. it worked once, then reverted back to not working =(.. oh well, I will figure it out eventually. thanks for the help.

    If anyone else has had similar problems, please post!


    IT WAS A FRIGGIN’ PLUGIN! Pazzey’s Store Locator plugin. Deleted it and everything is back to normal.. except I can’t use the store locator but FIXED!


    Glad you have it working again! Let us know if you have any more issues.



Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘My portfolio single page suddenly not working. Any ideas why?’ is closed to new replies.