Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #25548


    Today I tried to add a new item to my main menu on my website and it not only didn’t save it but also removed the prior 20 or so items on the menu, so now I have half of my menu available here:

    I recently have my site moved from a shared server to a private VPS one last night, however they have told me they moved the site over as-is and made no changes or anything. I had been changing shipping, products, everything today totally fine, the menu was as normal and fine, but then I went to add one item and now it’s broken. I have tried updating my theme in case, and adding another item but it won’t save past a certain number of items. I have been in contact with my provider but as my server is self managed they will offer little assistance. I have no idea how to fix this issue.

    If anyone can recommend assistance I would be so appreciative. Half of my products cannot be accessed.

    Thank you.


    Hi Femme_Fatale,

    First thing to try is disable all active plugins except for WooCommerce and then re-try editing your menu. Next is while plugins are still not active, increase your php memory limit using one or all of these techniques:

    WooCommerce and other plugins are steadily using more memory and its starting to really effect some servers where the default memory for wordpress is something low like 64mb. So upping it to 128 or even 94mb may help if the issue is with running out of memory when modifying the menu.




    Hi Devin,

    My memory is set at 94mb and I have just switched all of my plugins off excluding WC and tried to edit the menu but it’s not saving any items in the menu past a certain point. Is there anything else I can do?



    Sorry is anyone able to assist? Half of my product range can’t be accessed by visitors and customers, I urgently need to fix this :)

    Thank you!



    See (Purchase code hidden if logged out) -wordpress-custom-menus/ – probably a problem with the PHP/suhosin settings.

    Please don’t bump your threads (our queue system goes by oldest post first so when you self bump it actually pushes your topic to the back of our queue and doesn’t bring it to our attention quicker but it takes even longer) and a response can take up to 24 hours (depends on the number of requests)…




    Hi Peter!

    Thank you for your help. I’ve contacted my hosting company as they helped with this issue the first time I had it a few months ago. This is the response they’ve sent through for me:

    “Even though that stuff is in the php.ini. It doesn’t actually exist. suhosin is not active on your server so those settings are ignored.

    However. php_execution etc are. So if they can give you the values in php_values then we can set them for you.”



    In this case you can try to increase the php execution time (try 90 seconds) and the php memory limit.

    Best regards,




    This is the changes made:

    post_max_size 64M

    max_execution_time 120

    memory_limit 256M

    And unfortunately it hasn’t worked, the menu still is not saving items.



    These are the things you can do

    1.) Deactivate all plugins. If this works, re-activate the plugins one by one until you find the chaotic plugin(s).

    2.) Switching to the Twenty Twelve theme to rule out any theme-specific problems.

    3.) Resetting the plugins folder via FTP or PhpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    4.) Re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

    5.) Increasing the wordpress php memory limit.

    6.) Switch wp-config.php to debug mode. Edit wp-config.php, find this code

    define('WP_DEBUG', false);

    Set it to true.



Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Menu items not saving’ is closed to new replies.