Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #20686

    Sometimes (but not always) the automatic crop is cutting off an important part of my image. I see in the WordPress media library there is an “edit image” option, which allows you to move the crop, and designate whether this change applies to all image sizes, just the thumbnail, or all image sizes except the thumbnail. However, when I do it, it defaults back to the original crop. Is Replete preventing this edit?

    Is there a way to control the crop position on an individual basis? It’s really important that certain parts of each image are visible in the cropped product thumbnail.

    By the way, thank you for all of your help in this forum. You are great.



    no it’s not possible to control the crop position on an individual basis. You can hack the core files or use the filter function from here: (Purchase code hidden if logged out) / to change the crop position for ALL images.


    That’s too bad. My products are greeting cards and the captions are in various positions. In some situations they get partially cropped out. A great solution would be to display the caption rather than the product name in the area just under the image. Would that be hard to do?

    (I’m trying to avoid the site visitor having to click on the individual thumbnails just to see what the product is all about. They would get bored and leave the site, I’m afraid. Better to be able to get a good sense of them by scrolling through the site, then clicking on the one they like.)

    Thanks in advance.


    I’m so sorry but I have another problem, as long as you are here. (I’m sure you will be happy when my site is up and running so I won’t bother you so much. I know I will be!!!) I went through the Replete theme options > sidebar process to select my shop page and add specific Woocommerce widgets to the sidebar. I added Layered Nav and Recently Viewed, neither of which showed up. I tried Pages, just to see if anything would work. This did. But the Woocommerce widgets didn’t.

    Worse, when I set this new shop page as my official shop page in Woocommerce settings, the default widgets that come with the theme came back. But if I look at the appearance > widgets page, it still shows the two Woocommerce widgets that I put on my new shop page. What am I doing wrong? I don’t know if it’s a Replete thing or a Woocommerce thing or a WordPress thing. :(


    Hi creatorofstuff,

    The woocommerce shop page has its own sidebar which takes priority over all others. It should be listed as the Shop sidebar in the widgets section.




    Ok, I figured out that you have to use “shop overview page”, and not the actual page that you designate as your shop page. Huh. But still, the widget called Layered Nav does not appear, although Recently Viewed does this time.

    I wonder if I have incorrectly set up the criteria for the Layered Nav widget to work. I created attributes (in Products > Attributes), following the documentation here:

    They claim that this is how you can allow a site visitor to filter attributes to find a product. Ex. funny, birthday OR artistic, blank inside – that sort of thing. I set up attributes and then assigned the correct ones to each product. What is wrong here? I’m spinning my wheels.



    Oh sorry. I didn’t refresh the page. I figured with the time difference it was night there! I’ll work on that. In the meantime, do you have an answer to the question above, regarding the caption under the product thumbnail image? Can I change it from the product name to something else? Thanks!


    Hi creatorofstuff,

    Unfortunately I really don’t know of a way to do that. The product output is only modified with some wrappers as its just using the default woocommerce output of product title, price and sale tags.

    Getting the caption would require pulling the image data along with the attachment and then displaying it which I’m just not sure how to do within the shop output without re-doing that template completely.




    That’s unfortunate, but good to know. Thanks for clarifying.

    I’m still having problems with the Layered Nav widget not showing up. (I do have a side bar, am using the correct shop page, and everything else I put there shows up so I know it is done correctly.) I realize this could be a Woocommerce problem and not a Replete problem, but I have scoured the internet, searching on every term I can think of, and can’t find an answer. I’ve read all the docs for Woocommerce, too (which are pretty sparse).

    I also notice that the Woocommerce documentation seems to be contradictory. It tells you in the documentation “Custom attributes can be applied here too by choosing ‘Custom product attribute’ from the select box. These are added at the product level and won’t be available in the layered navigation.” However, if you go to Products > Attributes in the WordPress admin panel to set up the attributes, it says “You can use these attributes in the shop sidebar using the “layered nav” widgets.”. They are referring to the custom attributes that show up in the dropdown menu on the product page – the same one they say you can’t use in the documentation. And if you select these options, then “update”, they immediately disappear again, so it’s mute.

    There is also an option to type in a word, and those seem to stick on update, but still, no layered nav appears in the sidebar.

    I’m so frustrated and I don’t know where to turn. I spent many hours yesterday going in circles with this. Please can you help? Is it the combination of Woocommerce and Replete?

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘manually move crop position?’ is closed to new replies.