Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #457020

    I have multiple languages, all the LTR languages are fine, but on the Arabic pages, the logo is being pushed to the right side of the page.

    Using my ‘inspector’ if i delete the <dir=”rtl”> tag at the top, the problem stops… but that’s not a great solution because then I have to remove the <html <?php language_attributes(); ?>> part – which will affect all my other languages too.

    I’ve tried this and a few variations of it in the quick css, but it doesn’t work:

    .logo {
    text-direction: left !important;
    }

    Appreciate your help,
    Gabriel

    #457076

    I deleted <?php language_attributes(); ?> in the header.php and it’s working – but will this break other language elements? is there a better way?

    Thanks,
    Gabriel

    #457188

    Hey Gabriel!

    Can you provide a temporary access to see the site (it is on maintenance)? also, please revert language_attributes so we can see the actual issue.

    Cheers!
    Josue

    #457191
    This reply has been marked as private.
    #457223

    Hey!

    Try adding this code to the Quick CSS:

    #top.rtl .logo img {
        float: left;
    }
    
    #top.rtl .logo {
        overflow: hidden;
    }

    Cheers! 
    Josue

    #457236

    Didn’t work in the quick CSS, but when I added it to the “Edit CSS” block under appearance – it worked!
    Thank you!

    Gabriel

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Logo in WPML – RTL Breaking it’ is closed to new replies.