Tagged: ,

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #3714


    We’ve been using the Display theme for over a year now and love it. Unfortunately, due to all the changes we’ve made to the theme, we aren’t able to upgrade to its newest version. Recently we noticed the lightbox on our portfolio page isn’t opening correctly. Instead of opening lightbox it takes to you the image URL.

    Can you please help us figure out what the issue is. The portfolio page is located at http://www.jgvisual.com/web-design/.

    Thank you very much.



    we released an update for Display some days ago (you can download it @themeforest.net). If you don’t want to update (because of major customizations, etc.) you can just replace the lightbox files. Please refer to this thread: https://kriesi.at/support/topic/wp-31-breaks-lightbox for more information.


    That fixed the issue. Thanks a lot. And for all those who want to customize prettyPhoto, go to this link on the prettyPhoto website: http://www.no-margin-for-errors.com/projects/prettyphoto-jquery-lightbox-clone/documentation/. See the bottom of the page for customization options.

    You can make edits to how prettyPhoto is shown for the display theme in js/custom.js.

    Thanks for your help,.


    Sorry to revisit this topic, but we noticed an issue when upgrading to the new version of prettyPhoto. On our homepage at http://www.jgvisual.com there is only one image to show. When you open that image in prettyPhoto the previous and next buttons come up even when there is only one image. What can we do to fix this?

    Thanks again for all your help.



    I think this is a bug with the script, I’ve noticed this on a couple of sites using it.

    It may be worth asking in the author’s support forum for help with this: http://forums.no-margin-for-errors.com/categories/2/p




    I think it may be an issue with the way Display shows the single image in the homepage. To show a gallery you put rel=”lightbox[boxes]” with the name of the gallery in brackets[]. For a single image I think you want to write rel=”lightbox” only without the brackets. Is there a way to make it so those brackets aren’t added on the homepage with one image, but are added on the portfolio page?

    Thanks a lot.



    as far as I can see it’s only possible by modifying the post thumbnail generation code. Open up kriesi_build_image.php (located in displayframeworkhelper_functions) and replace following code:

    $lightbox = $option['lightbox'] != '' ? 'rel="lightbox['.$option['lightbox'].']"' : '';


    $lightbox = $option['lightbox'] != '' ? 'rel="lightbox['.$option['lightbox'].']"' : '';
    if (is_home() || is_front_page()){ $lightbox = 'rel="lightbox"'; }



    Thanks for the feedback. I tried this method and it doesn’t work. Even though I’m on http://www.jgvisual.com WordPress doesn’t see it as the homepage or the front page. Is there anything else I can use in the if statement to signal to WordPress that this isn’t a portfolio page?


    I don’t know another methode – other themes use custom post types for portfolio pages but Display doesn’t. There’s no conditional tag I can use (like for Avisio where you could use get_post_types(). You can set a global variable and write read it depending on some parameters but this solution takes some time and is beyond the scope of this support forum.


    Hey Dude,

    That was all the suggestion I needed. Here is what I did:

    – at the top of index.php just below get_header(); I declared a variable $homepage and set it to true ($homepage = TRUE;)

    – In kriesi_build_image.php I added the following two lines below the line $lightbox = $option != ” ? ‘rel=”lightbox.’]”‘ : ”;

    global $homepage;

    if ($homepage){ $lightbox = ‘rel=”lightbox”‘; }

    That’s all it took. Thanks a bunch for your help.


    Glad that you found a solution. Easier than I thought – sometimes global variables can be a hassle :)

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Lightbox Not Working Correctly’ is closed to new replies.