Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #18069

    Hello, have an issue with the layer slider plugin not showing when the shortcode is used inside a dynamic template text area element on the homepage. It was working great prior to updating to the latest version, now it seems to block all of the content from appearing? Any help or ideas as to why would be appreciated. Could possibly be on the plug-in end too I suppose. Thanks in advance.



    Sorry for the delay, my mistake. I am sorry.

    How did you update? By deleting all your files and replacing the entire folder? If you put the old version of the theme back, does everything work again? By ‘not working’ do you mean that you see the shortcode inside the square brackets, or there is an empty space in place of it?

    Have you added any plugins after the update? Does every shortcode fail to work for you or only some?

    Can you create a separate development site locally for example, and try to recreate the issue with a fresh wordpress and theme?




    Hey thanks for the reply. Seems to be a .js issue, I did the standard replace all the files via ftp for the update of the angular theme. The element that the shortcode calls for will appear as an empty space with the correct dimensions however the slider with images does not appear. Using firebug I can see that the script for the slider plugin gets put way at the top of the html markup before even the doc type. The very first thing. Using Firebug I can remove it and place the code in the proper place above the actual element below the head tag and everything works as it should, but I’m not certain how to fix this in the wordpress/theme coding?

    *No other plugins were installed prior to me updating the theme that weren’t installed before when everything worked.

    *The built in shortcodes with the theme do appear as normal

    *The layerslider plugin does appear on pages/posts that don’t use the dynamic template feature

    I think something must have gotten a little funky when I updated the theme and the plugin around the same time. Any ideas? Again, thanks for the help.




    Can you post a link to your website please? I’d like to debug the js code.

    Best regards,



    Put up a test page with the layer slider plugin:

    Thanks again for the help,



    Hi -B,

    I checked the source of your site and I can see this on the top, before the html tag:

    <script type="text/javascript">


    width : '940px',
    height : '340px',
    responsive : false,
    autoStart : true,
    pauseOnHover : false,
    firstLayer : 1,
    animateFirstLayer : false,
    twoWaySlideshow : false,
    keybNav : false,
    touchNav : true,
    imgPreload : false,
    navPrevNext : false,
    navStartStop : false,
    navButtons : false,
    skin : 'noskin',
    skinsPath : '',
    globalBGColor : 'noskin',
    yourLogo : false,
    yourLogoStyle : 'position: absolute; left: 10px; top: 10px; z-index: 99;',
    yourLogoLink : false,
    yourLogoTarget : '_self',

    loops : 0,
    forceLoopNum : false,
    autoPlayVideos : true,

    autoPauseSlideshow : 'auto',
    youtubePreview : 'maxresdefault.jpg',

    cbInit : function() { },
    cbStart : function() { },
    cbStop : function() { },
    cbPause : function() { },
    cbAnimStart : function() { },
    cbAnimStop : function() { },
    cbPrev : function() { },
    cbNext : function() { } });

    Kindly put it in footer.php just above </body>. Hope this helps. :)





    Yes, your plugin is injecting its jquery code (see above post by Ismael) on the 3rd line of the site, before jquery is even defined. Have you tried re-installing the plugin?

    Here is a new video from its developer



Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Layer Slider Shortcode issue’ is closed to new replies.