Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #19046

    Hey, I have a site I made live a few days ago… it’s running WPML 2.6.0 (latest WPML is 2.6.3 or something). When I made the update the portfolio section I have stopped working. I tried every other plugin going on and off and resetting the permalinks, etc., and it was only fixed when I re-uploaded the older version of that plugin.

    Will there be a new Choices update going out soon, or is this a WPML problem?

    I’d like to have the latest software on the site soon.

    That’s the site that has the older version of WPML on it. I’ve also got the test version at that I would like to test whatever changes to before making them to the live site.


    Hi andreanapier1985,

    I’ll tag this for Kriesi and Peter. If there is a need for an update it will get done but we can’t typically provide an ETA on when a release will be.

    From the changlog, it doesn’t look like it should be causing any issues however.

    What exactly doesn’t work when you upgrade? can you go into specifics on what happens with your portfolio section?




    When I update WPML to anything PAST 2.6.0 (I’ve tried 2.6.1, 2.6.2 and 2.6.3) the page can’t find any portfolio items on a page and produces a “Not found” message.

    This is an example of what happens when I update.

    This is an example of what happens on the older version of WPML.




    On the page in template builder, where you add the portfolio-categories to display, would you try and not select any category at all, just leaving it as though you don’t want to display any of them and save. Does that make the page that displays the portfolio items work again showing all categories?





    Ok, Here is the fix for the problem:

    In the plugin folder, look for a folder called: sitepress-multilingual-cms

    Please find line 3625 of file sitepress.class.php which looks like

    if(is_tax() && is_main_query()){

    and change it to look like


    The line number may be different depending on your version of wpml. this is for version 2.63. You can use the find command to search the file for the line of code.

    Please let us know if it worked out.




    Yes, that fixed it right up!

    Thanks so much!





Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Latest WPML breaks Choices Portfolio section’ is closed to new replies.