Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #1038697

    Hi, I have the same Issue like that user: https://kriesi.at/support/topic/ (Purchase code hidden if logged out)(Purchase code hidden if logged out) /

    My provider changed to PHP 7.2. Most of the function working proper. But I’m not able to enter the area with customer orders within WooCommerce. Error message is “Error thrown – Cannot use string offset as an array”. Probably the Plugin “WooCommerce DE Avia Themes Anpassung” is also affected?

    Made you an Admin account. I couldn’t find an update of the theme and have no idea what I have to change.

    Thank you.

    Regards,
    Frank

    #1039419

    Update: When I change the Theme to standard Theme “Twenty Fifteen”, everything seems to work properly. Since the last update of the Theme is from 2016, is there a plan in general to update the Theme or is this a dead end?

    Frank

    #1039422

    Hi, I could fix it with the new combat.php – Still open is the question for the next planned update of Propulsion. Then, topic can be closed.
    Thank you!

    #1040704

    Hi,

    I’m sad to say that there won’t be any new updates or improvements for this theme but we will keep supporting it in the upcoming months and it will be completely remove from themeforest after that. The theme is quite old, more than 7 years, and it is no longer viable to maintain them. This is mainly caused by the fact that themeforest, rather than requesting users to renew their license each year, have added the “support packages” which really can’t cover the ongoing development costs for themes that had their prime years ago. We will solely focus our attention on Enfold, the latest theme, in case you’d like to check it.

    Thank you for understanding.

    Best regards,
    Ismael

    #1040731

    Hi,

    good to know. Thank you for the information!

    Is it expected from your site, that there might be some more upcoming issues with the theme like the one above or similar in respect of php 7.X ?

    Best regards,
    Frank

    #1041073

    Hi,

    Yes, it is expected because the theme is quite old as I said previously, so some of its code may not be compatible with the latest PHP version. The site is probably better off on version 5.6 if security is not an issue.

    Best regards,
    Ismael

    #1060190

    Frank, can you post how you fixed it? I searched combat.php but I’m not finding anything. I have the same issue with the PHP being upgraded.

    Thanks!

    #1060195

    I’m getting a white screen, and in the backend Propulsion gives this error.

    Error thrown

    Function name must be a string

    Edit: I found the compat.php file in another thread, but it doesn’t fix the issue on my site.

    • This reply was modified 7 months, 3 weeks ago by  gensd. Reason: Updated with new info
    #1060938

    Hi,

    @gensd: Please open a new thread and put the WP and FTP login details in the private field. We’ll check it there.

    Best regards,
    Ismael

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Issue with PHP 7.2 – "Error thrown – Cannot use string offset as an array"’ is closed to new replies.