Tagged: ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1051506

    Hi, I have a site that uses the Incarnation theme and since updating to WordPress 5 and Gutenberg, I’m unable to edit pages that contain a Classic block in the Gutenberg editor that contains WordPress shortcodes (apparently). Here’s the error I’m seeing in the Google Chrome Inspector Console:

    Uncaught TypeError: wp.shortcode is not a constructor: media-editor.min.js?ver=5.0.2&nocache=1:1
        at Object.shortcode (media-editor.min.js?ver=5.0.2&nocache=1:1)
        at n.initialize (mce-view.min.js?ver=5.0.2&nocache=1:1)
        at n.b.mce.View (mce-view.min.js?ver=5.0.2&nocache=1:1)
        at new n (load-scripts.php?c=0&load[]=hoverIntent,common,thickbox,underscore,shortcode,media-upload,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&load[]=,admin-bar,jquery-ui-resizable,jquery-ui-draggable,jquery-ui-button,jquery-ui-position,jquery-ui-dialog,heartbeat,postbox,backbo&load[]=ne,wp-util,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-request,media-views&ver=5.0.2:452)
        at Object.createInstance (mce-view.min.js?ver=5.0.2&nocache=1:1)
        at mce-view.min.js?ver=5.0.2&nocache=1:1
        at Function.m.each.m.forEach (load-scripts.php?c=0&load[]=hoverIntent,common,thickbox,underscore,shortcode,media-upload,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&load[]=,admin-bar,jquery-ui-resizable,jquery-ui-draggable,jquery-ui-button,jquery-ui-position,jquery-ui-dialog,heartbeat,postbox,backbo&load[]=ne,wp-util,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-request,media-views&ver=5.0.2:346)
        at mce-view.min.js?ver=5.0.2&nocache=1:1
        at Function.m.each.m.forEach (load-scripts.php?c=0&load[]=hoverIntent,common,thickbox,underscore,shortcode,media-upload,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&load[]=,admin-bar,jquery-ui-resizable,jquery-ui-draggable,jquery-ui-button,jquery-ui-position,jquery-ui-dialog,heartbeat,postbox,backbo&load[]=ne,wp-util,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-request,media-views&ver=5.0.2:346)
        at Object.setMarkers (mce-view.min.js?ver=5.0.2&nocache=1:1)

    Can you please provide a solution for this issue? The Classic block in the above case is completely unusable.

    Thank you,
    Jutta

    #1051973

    Hey livingmiracles,

    We will not be making this theme compatible with Gutenberg, unfortunately.
    Please refer to the reply here
    https://kriesi.at/support/topic/ (Purchase code hidden if logged out)(Purchase code hidden if logged out) -offset-as-an-array/#post-1040704

    If you need further assistance please let us know.
    Best regards,
    Victoria

    #1053205

    Hi Victoria,

    Thank you for your response. Can you recommend a theme that we can use on our current Incarnation site? Some theme that we can easily switch to without too much extra work?

    Jutta

    #1053310

    Hi Jutta,

    We will be a one product company from now on, we will only develop and maintain the Enfold theme. You will still have to recreate most of your content if you are going to switch themes unfortunately.

    Best regards,
    Rikard

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.