Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #495566

    I’ve been playing with the theme today, but haven’t been able to figure out why the images on my install don’t behave like they do in the demo.

    In the demo, hovering over the image creates a transition effect and that’s it. But on my install, hovering also increasing the margin/padding above and below the image, causing the elements on the page to shift.

    Also, in Firefox (but not in Chrome), aligning “left” or even “none” causes the image to break out of the page — only aligning “center” seems to work right.

    Did something go wrong with my install? How do I make it work correctly?

    #495859

    Hi xscapist,

    The link you sent seems to be down, did you remove or move it somewhere else?

    Thanks,
    Rikard

    #495903

    The install is still there, and the link is working for me currently (I checked on a few different browsers and devices just in case, and it’s still there). It’s possible the host could’ve been down briefly at the exact moment you checked.

    #496233

    Hi,

    It doesn’t seem to be down anymore but it’s still not loading on my end, I get a No data received ERR_EMPTY_RESPONSE error message. Not sure why though?

    Regards,
    Rikard

    #496427

    I’ve been checking with friends in different countries using different browsers, and no one else is having a problem. Could it be something on your end?

    #496496

    After browsing other sites that use the Sentence theme, I’ve confirmed that’s it’s not a problem with my install, but a problem with how the theme’s lightbox is coded. Featured images are fine, but body images have an issue where the margin/padding increases on hover, causing the page to shift in an unappealing way, as in this example from a different blog.

    It looks like most Sentence users get around this problem by removing the larger view link from their images, making them not clickable, so that nothing happens on hover.

    Unfortunately, I don’t have the time to go back through 150 blog posts to either remove the larger view link or to set each to “align center,” so I’m probably going to have to go with a different theme. It’s disappointing, because I like how stylish the theme is other than the glitchy lightbox hover. But even more unfortunate that I probably can’t apply for a refund for something that’s merely glitchy instead of broken.

    #497050

    Hey!

    try this code in Quick CSS field:

    .six.units.entry-content {
    pointer-events: none;
    }
    

    Cheers!
    Andy

    #497064

    It didn’t work, unfortunately, but thanks.

    #497067

    Hey!

    the code should work. Try to clear browser cache and hard refresh a few times. If there are no changes for you then provide us admin access, so we can have a deeper look. Post login details here as private reply.

    Regards,
    Andy

    #497091

    I cleared the cache and tried a few different browsers, but still no go.

    I spotted a different style of WordPress theme that I want to try out instead, so I’d feel guilty having you put a bunch of work into finding the problem only to switch to a different theme right after.

    That said, I have a feeling all installs of the theme have this same issue, and if so, it might be nice if it gets fixed in a later update. Try doing a test install somewhere, and just post some non-featured images in the body of a post, with a link to view a larger version.

    That one example above of someone using Sentence is the only instance I could find where someone had a body image that could be viewed larger, and it had the same issue, but numerous other blogs I found with body images simply removed the URL so it couldn’t be viewed larger, and I have a feeling at least some of them removed the URL so the elements wouldn’t jump around. If true, having that fixed might make a lot of users happy.

    • This reply was modified 4 years, 2 months ago by  xscapist.
    #497577

    Hey!

    would be good if you provide us admin access, so we can check what’s going on. It’s definitely not normal theme behavior and on my installation it’s working as expected. Are we allowed to deactivate all your plugins temporarily? please post admin login here as private reply.

    Cheers!
    Andy

    #498759

    I already switched to a different theme before your reply, but I do want to help fix these bugs if they’re happening for other users, so I set up a fresh test install with no activated plugins. I’ve created a test post with in-post images with different settings:

    http://www.swipeoftheweek.com/test/2015/09/05/hello-world/

    In Chrome, “Align: Center” causes elements to shift when the image is hovered over. “Align: Center w/ Caption” doesn’t cause a shift, though there’s some odd white space between the top of the image and the gray border around the image.

    In Firefox, all of these images break outside of the post except for “Align: Center,” which still causes elements to shift when the image is hovered over.

    I’ve included an admin login in the Private box.

    #499172

    Hey!

    your wp-admin url is not working for me, I get a “Not Found” error. Did you change login URL? please provide us a correct link.

    Best regards,
    Andy

    #499281

    Sorry, I typed the URL wrong.

    #499388

    Hi!

    I tried to reproduce the issue on my own installation, but it works fine for me and does not behave like in your case. Do you have some custom CSS code in custom.css or anywhere else? Try to delete all theme files via FTP and get a fresh copy from your themeforest account.

    Best regards,
    Andy

    #499404

    This was a fresh install with nothing changed, added, or modified.

    #499639

    Hi!

    Please try to add this in the Quick CSS field to remove the “shifting” on hover:

    .entry-content p a:hover {
        padding: 0;
        margin: 0;
    }

    Add this one to fix the images on firefox:

    .entry-content img, .entry-content a img {
        width: 100%;
    }

    Best regards,
    Ismael

Viewing 17 posts - 1 through 17 (of 17 total)

You must be logged in to reply to this topic.