Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #237766

    I’m trying to use a cufon font (the true type font Avenir) in my website but something is not working properly.
    I’ve followed all the indications explained in and and I’m able to select that font in the theme option panel.
    But when I try to enter a text using the font family “avenir” or even “cufon” the text doesn’t appear with the right cufon font but with an extremely generic times new roman.

    For instance you can see in this page ( that I’ve tried to use the Avenir cufon font in all the right sidebar but noone of the texts (PHOTO GALLERY TRAVEL, ADVENTURE TITLE CONTENT, PICTURE STORY) appear with the right cufon font…

    can you please suggest me what I should do to fix the problem?
    thank you!


    Hi matteora!

    Please make sure you type in “cufon” in the font family field: . At the moment the font family is set to “avenir-heavy” and the theme won’t load it.

    Best regards,


    Hi Dude,
    thank you for the reply.
    I had actually set the font family field as cufon at first, but I had the same problem so I tried with another name.
    Currently I’ve used again the name “cufon” in that field but apparently it’s still not working.
    Do you mind explain me what I’m doing wrong?
    Thank you!



    Pleae open up wp-content/themes/shoutbox/js/avia.js and search for:

    var elString = 'h1, h2, h3, h4, h5, h6';

    – this string/code line contains all elements which will be replaced with a cufon font.I noticed all your headlines use spans or strong tags and you do not use h1 – h6 tags. You’ve two options:

    1) Add these tags to your content – it would also improve the seo because the hX tags mark the headlines for the search engines. spans are not recognized as headlines.

    2) Add your tags to the element list – i.e .like:

    . `
    var elString = ‘h1, h2, h3, h4, h5, h6, span’;
    the disadvantage of this solution is that inline spans are also affected and this might break the text layout.



    Thanks a lot Dude,
    I’m using the h1-h6 tags and now the cufon is correctly recognized!

    Thanks again



    Great :)


Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.