Viewing 30 posts - 1 through 30 (of 43 total)
  • Author
  • #3167

    Hey guys, bit of a big one!

    Just downloaded wordpress version 3.1 as an update, and now when clicking on a post under any of my portfolio pages (- Top right –

    ‘ei candy’ & ‘exclusives’) the content is now not there, and comes up with Error 404 nothing to be found. This is present on all posts!

    Please help guys!

    Thank you!



    try to flush your permalinks. Go to settings > permalinks and click on the “save” button – hopefully this will fix the problem :)


    Thanks Dude, that worked a treat! However, now I have to have the permalinks set to default, and not on ‘month & name’ for them to work which is a little frustrating.

    Any thoughts?

    Thanks so much for getting back to me so quickly. I’ve noted that tip for the future!


    Ok so no, actually the update has buggered up all the permalinks and now they wont work.

    what used to be – – (year/month/sample post) now will not work, and i cannot use the default setting as I need to use a cache and this requires a custom permalink to work.

    This also fails to work for the portfolio pages, as it cannot find any of the content on any custom urls other than default and brings up a 404.

    It is currently set to default.

    Thoughts would be greatly appreciated!




    please check your htaccess file. Maybe WP can’t/doesn’t write your permalink changes to it. Please refer to: for more details.


    This is a massive issue that needs fixed ASAP. My htaccess is writeable, I’ve changed permalinks to default, tried different variations and still my pages won’t load up. The blog posts work fine, just not pages like in portfolio etc. HELP!!!


    Which WP version do you use at the moment?


    +1 but i am on avisio theme

    using 3.1, everything works except portfolio pages…


    i mean, portfolio pages work but when i click read more link that brings 404


    Sorry I’m also on WordPress 3.1. It’s a huge loss for us at the moment. Hopefully there’s a fix soon!


    I have the same issue on my site….using AVISO with WordPress 3.1 all of my links currently work using this structure


    EXCEPT for the portfolio pages I have, none of the image links or the read more links work now they all dump me on a 404 error page…..

    I went into WordPress and just to test I changed my permalink structure back to default and the portfolio stuff worked again but that means all of the other links I have set up on my site are now busted….so really the issue just needs to be corrected with the custom post type that is being used for the Portfolio stuff…..PLEASE HELP!

    You can see what I mean here:



    Same here, Aviso, WordPress 3.1


    I also have the same problem with my website also. theme is habitat and wp3.1 update was done. yo can check it here.

    I think we need a theme update ASAP



    we have also problems with the Aviso-Theme (Portfolio Items)

    Permalink structure default – OK

    Permalink “postname” (our favorite) – 404 error

    pretty photo also not working – NGG with Thickbox works.

    Need asap info or update to fix the Portfolio/Permalink/Category Problem



    There is a comprehensive list of 3.1 troubleshooting bugs and fixes here: (Purchase code hidden if logged out)

    We are looking into the various bugs created by WP 3.1 and will update the themes where necessary ASAP.



    Same here, Aviso, WordPress 3.1


    Thanks James, I tried doing what the article suggests (hitting save and deleting the htaccess file) but still don’t see any results. I’m still getting a 404 error on my permalinks. Any suggestions on a fix? Thanks!


    Any solutions forthcoming?

    I am glad I was only partly into my portfolio set up when this all broke, it has been a ton of work.

    I have found the support for this theme not top notch. I think I am going to just switch back to Studio Press themes for now.

    The Avisio theme is very cool, but I can’t wait days or weeks for answers like this.


    I’m sorry to hear this but you can downgrade to WP 3.0.5 for now and Avisio will work again. We update Avisio soon.


    is the solution near?

    i cant do a database restore, its not an option, is it possible to downgrade without db restore, only files overwrite, waiting you to solve the problem i imported 30k pictures in nexgen gallery, today i must do another 20k..

    this is bad….



    I can’t give an exact date but I expect the update this week…


    Update: I think I found the cause of the permalink problem. I post my solution here – I’d be glad if someone could test it. My permalinks work without problems so I compaired my settings with the standard one and noticed that I removed the category base slug. To remove it open up portfolio.php located in the folder “theme_options”. Search for following line:

    if($slugRule == "") $slugRule = 'category';

    and replace it with:

    if($slugRule == "") $slugRule = '';

    Afterwards go to Settings > Permalink and check if the “Category base” field is empty. Click Save. The permalinks should work now.

    In conclusion the problem is the SlugRule which must be empty. If a category base or the standard configuration is used (slugrule = “category”) the permalink doesn’t work anymore.


    yees =)

    problem solved…

    many thanks for support..


    Works for me too. Thank you very much!


    You are a HERO. Thanks so much dude, it works a treat!


    Glad that I could help you with a temporary fix :)


    Sweet. That worked for me as well (running Aviso). Thanks so much for the fix.


    Thanks for the fix! Works perfectly!


    Great, thanks – this works perfect.


    Ok. Quick update to everyone using the fix provided above Dude. It will fix your main top level portfolio but any sub-portfolios you have created will not work anymore….well at least mine don’t. On my site: I am using WordPress 3.1 with the fix implemented by Dude.

    If you click on the large “View Our Work” button on the homepage it takes you to the main level portfolio and all is well and links work just fine……


    If you go up to the main menu and hover over Websites and then click on Website Samples (this is a link created in the menu system that links to a sub-portfolio) it gives the 404 error still. I am no expert when it comes to the code that runs these things but it would seem that the temporary fix dumps any category association with the portfolio now other than the main portfolio it self.

    Am I missing something here or is this how it is for now until the official theme update is available later this week?

Viewing 30 posts - 1 through 30 (of 43 total)

The topic ‘HELP! WordPress update has broken habitat!’ is closed to new replies.