Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #983699

    Hi,
    there is a problem with the Google API key. After update to enfold 4.4.1 the key does not work anymore. Every attempt to activate the key again in enfold settings fails. I assume, it is a connection problem between enfold and google.

    • Upate via FTP: first delete the old folder, then upload the new one
    • My google account is okay (billing address …)
    • The Key is okay: I am running now the map with annother plugin and it works fine

    What can I do?

    Best regards,
    Günter

    #983744

    Same problem here. Maps suddenly don’t work any more on my site!

    #983831

    Hi,

    Please create a separate post for us to review so we can help you.

    Best regards,
    Basilis

    #984887

    Hi Basilis,

    the login credentials…
    At the moment Google Map Element is deactivated in enfold settings.

    Best regards,
    Günter

    #985063

    Hi Günter,

    Please activate it so that we can see the issue.

    Best regards,
    Victoria

    #985099

    Hi Victoria,

    on Page https://ifa.or.at/work/ (https://ifa.or.at/ifawp/wp-admin/post.php?post=2542&action=edit). You find the valid API key in the pivate section.

    Best reards,
    Günter

    #985828

    Hi,

    We get these errors in the console when we try to authenticate the API key.

    Google Maps API error: InvalidKeyMapError https://developers.google.com/maps/documentation/javascript/error-messages#invalid-key-map-error
    _.Pb @ js?v=3.30&key=ADD KEY HERE:38
    Geocoding Service: This API project is not authorized to use this API.  For more information on authentication and Google Maps JavaScript API services please see: https://developers.google.com/maps/documentation/javascript/get-api-key
    _.Pb @ js?v=3.30&callback=av_backend_maps_loaded&key=AIzaSyBee-OpiXkJ7lldt-HcF-JvifEw25fsxfo:41
    util.js:248 Google Maps API warning: RetiredVersion https://developers.google.com/maps/documentation/javascript/error-messages#retired-version
    

    Please enable the Geocoding Services API from the API manager. Generate a new key and make sure that the Key Restrictions is set to “HTTP referrers (web sites)”.

    Best regards,
    Ismael

    #986034

    Hi,
    I have the same issue here.
    I activated Google Cloud Platform, provided credit card credentials etc., API key is valid but still with the lastest update something changed so that I can’t use Maps anymore. Someone recommended a plugin to help. Could you please tell me which one that is or provide another idea to fix the issue.

    Thanks a lot in advance
    Mischka

    #986212

    Hi,

    Please enable the Geocoding Services API from the API manager. Generate a new key and make sure that the Key Restrictions is set to “HTTP referrers (web sites)”.

    @mischka_b: Have you tried that? Please create a new thread with the site url and the login credentials. We would like to check it.

    Best regards,
    Ismael

    #986469

    Hi Ismael,

    it does not work. I enabled the Geocoding Services, generated a new key and set to “HTTP referrers (web sites)”.
    On enfold settings “Check API Key” ends with: “Could not connect to Google Maps with this API Key.” And on page /work/, when I try to insert a map, the error is: “It seems that your Google API key is not configured correctly”

    Maybe can You give me a Google-valid email address. Then I will create a new user inside Google Cloud IAM for you. Please set your user account to that address. Maybe can you detect, inside Google what is going wrong.

    Best regards,
    Günter

    #986717

    Hi,

    I don’t see the “Geocoding Services” error anymore so it’s a good thing. It means that the API is enabled now but I’m getting a new error related to the key restrictions.

    Google Maps API error: RefererNotAllowedMapError https://developers.google.com/maps/documentation/javascript/error-messages# (Purchase code hidden if logged out) 
    Your site URL to be authorized: https://ifa.or.at/ifawp/wp-admin/admin.php?page=avia
    

    You need to allow the site to use the key. Try to use wildcards in the HTTP referrers field.

    Example:

    *.ifa.or.at/*
    

    Or:

    *.ifa.or.at/ifawp/*
    

    Best regards,
    Ismael

    #987224

    Hi,

    The allowed URL were registered. After adding the explit URL “https://ifa.or.at/ifawp/wp-admin/admin.php?page=avia” from above the “Check API Key” in enfold settings works. But inserting a map does not work. Please look at the error message in screenshot.

    I tried a lot of URL and wildcard versions. This is the current state.

    Best regards
    Günter

    #987368

    Hi,

    The “Check API Key” worked after the “Geocoding Services API” was enabled. Please remove all https referrers and use the ones above. You may need to wait for a few minutes before the changes take effect.

    Best regards,
    Ismael

    #987711

    Hi Ismael,

    It does not work. An “InvalidKeyMapError” stays, whatever I try. Inside Google Cloud platform I found no usefull further instructions. Maybe a server misconfiguration, maybe a plugin – I surrender. IFA needs a Map. I changed to a third party plugin.

    Thank you for your help.
    Best regards,
    Günter

    #987857

    Hi,

    I’m sorry to hear that. The setup seems correct but it’s still not working. Please try this plugin.

    // https://wordpress.org/plugins/ (Purchase code hidden if logged out) /

    Best regards,
    Ismael

    #988131

    Hi Ismael,

    I think it has it has to do with the server settings, ifa.or.at switched recently to https.

    But all in all I must say: The new API system is a little bit overdone. You have a domain authentication. For which security relevant situations do you need additional URL restrictions?

    I hope, You are not disappointed about that unsolved case.
    Best regards
    Günter

    #988542

    Hi,

    This is the error in the console.

    js?v=3.30&key=ADD KEY HERE&callback=aviaOnGoogleMapsLoaded:41 Google Maps API error: InvalidKeyMapError https://developers.google.com/maps/documentation/javascript/error-messages#invalid-key-map-error
    

    There’s an extra “ADD KEY HERE” strings in the “key” parameter. Did you modify the theme files?

    js?v=3.30&key=ADD KEY HERE&callback=aviaOnGoogleMapsLoaded:41
    

    Best regards,
    Ismael

Viewing 17 posts - 1 through 17 (of 17 total)

You must be logged in to reply to this topic.