Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
  • #17567


    It seems no matter how I set up woocommerce pages they won’t show the fullscreen slider controls. I can live with the default gallery as a background (something I’ve also noticed happening that I’d guess it’s related), but is there something I can do to have said controls back?

    They appear in single product pages just fine.


    Hey jmlfernandez,

    Just under the visual editor you should see “Gallery Options” where you uploaded the product image. You should be able change the background gallery options with the options “Enforce Default Background” and “Background Gallery controls” to choose to show the controls or not.




    Single product pages do work flawlessly, as you point out.

    However, I’m having issues getting said options to work in the “shop base page” (as set in WooCommerce/Settings/Pages tab) and “product category” pages. In these two specific cases, the default gallery is being used by the background slider, but there are no controls for it (which I assume would be the default setting for this feature).

    I don’t mind having the default gallery set as a background, so I guess my specific issue would be solved if I could somehow set the default to “show controls”. Is there any way I can do that?

    Thank you so much for your time, really appreciate the speedy response.



    Not that I know of no, but let me tag this question for another of the support crew who might be able to give a concrete answer one way or another.




    I’ve been taking a look at the core template files myself, trying to achieve my goal. Unfortunately, I’ve had no success yet.

    Any specific advice on where to look for it?

    Thanks for your time.



    To better understand what you want to accomplish. You want to add a full screen gallery to (a) WooCommerce Shop Main Page (b) WooCommerce Category pages ?

    Can I see the page in question? Please provide a link. Maybe can cobble up a bit of jQuery specific to those pages and switch out the images. I rather not build a test page for that but see your pages.




    I would like to enable the controls for the background slider shown in the WooCommerce base page and product category pages.

    There’s already a fullscreen slider, it’s using the gallery designated as default (something I actually want), but no controls for it.

    Unfortunately I can’t provide you with a link since this is a WIP and our development environment doesn’t allow for external access.

    However, your live demo also seems to be affected by this issue:

    As you can see, there’s a gallery showing in the background slider which I assume is the default gallery, but there are no controls for it, and even if you change which gallery to show on the slider in that page (or either if you want controls for it or not), it will keep using the default settings (default gallery and no controls). There’s apparently no way to change these settings (or other settings for that matter) in product category pages, though.

    So, I would really appreciate if you could direct me to which template file I should modify to have the “show controls” set to “enabled” by default, since this would solve my specific issue.

    Again, thanks for your time and assistance, really appreciate it.




    Please use this plugin (Purchase code hidden if logged out) -slider/ its free an has a paid version (Purchase code hidden if logged out) -slider-plugin-for-wordpress/

    I used the free version right now and successfully put a background gallery to the shop page (the one whose url on demo you pasted).

    Looks real sharp, you should try it out, it wasn’t disappointing like the first 2 plugins i tried.

    To get the free one to break out of woocommerce control, please add this to your Quick CSS or custom.css

    #fwbslider {
    z-index: 0;
    .fwb_fromthis {
    display: none;




    Thank you so much for your response.

    However, is there some way I can use the slider included in the template?

    I believe it’s somewhat redundant using another plugin to accomplish something that the template already has the capability to do, apparently.

    For my specific issue, I just need to be able to set the default setting for “show controls” to true, and I sincerely believe there should be some place in the code where I can modify this. I will try snooping the template files for some more time and then try your solution though, I was just asking for some assistance on locating where to do so exactly.

    Again, thanks for your time.




    Ok suit yourself. The control is located in file avia_fullscreen_slider.js in folder /js/ of the theme’s root. Its inside that huge continuous block of code starting from the start and going halfway into the file.

    Around the center of it there is a line


    Now starting from that line going down are the slider controls.




    Okay, I got it at last.

    Turns out when loading a page where avia_is_overview() returns true it applies some hardcoded settings by default, just as I’ve been suspecting all this time.

    I was able to tailor this behavior to my linking by modifying the line #32 from “includes/helper-slideshow.php”.

    Now the slider controls will always appear on the desired pages.

    Thanks for your time guys, really appreciate the assistance.

    Also, I hope this can be used to help someone in the future, or even taken into account in future updates/development.




    We really appreciate you taking the time to post the solution and help those who are yet to travel this path. I rarely handle requests for this theme since it is so original , most people leave it as is. But the few who do are sure to benefit from this.



Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘Gallery controls on woocommerce pages’ is closed to new replies.