Viewing 30 posts - 1 through 30 (of 33 total)
  • Author
    Posts
  • #773363

    Hi,

    My footer in the french homepage of my site is full width (https://www.imt.fr/).
    But the english homepage is 100% and I can’t change it to full width (https://www.imt.fr/en/).

    Obviously, all parameters are exactly the same…

    Could you help me ?

    Thanks
    Oli.

    #773573

    Hey Oli!

    What are your Grid settings form the Theme Options?
    Can you please check?

    Cheers!
    Basilis

    #773946

    Hi,

    I’ve checked, there are the same as the french version of the homepage. Here is a screenshot :
    https://partage.mines-telecom.fr/index.php/s/qHF8zd88GEllnwE

    Regards,
    Oli

    #773952

    Hi,

    Please post us your login credentials (in the “private data” field), so we can take a look at your backend.

    Login credentials include:

    • The URL to the login screen.
    • A valid username (with full administration capabilities).
    • As well as a password for that username.
    • permission to deactivate plugins if necessary.

    Best regards,
    Yigit

    #774093

    Hi,
    OK, I’ll send it on april 18th, I’m away from my office next week.
    Please don’t close this topic.
    Regards,
    Oli

    #774861

    Hi Oli,

    No problem, we’ll keep the thread open for you.

    Best regards,
    Rikard

    #779224

    Hi,
    here are the credentials. Please don’t deactivate plugins for the moment.
    Thanks,
    Oli

    #779358

    Hi,

    I created a private testing page and it does work fine. I believe it has something to do with plugins. Could you please try de-activating them all to check if that helps?

    Best regards,
    Yigit

    #779363

    Yes, all pages works fine in the english version of the site except the homepage…
    Any solutions before I try deactivating all plugins ?

    #779368

    Hi,

    I believe some plugin is applying some codes on your homepage which is causing the issue. As can be seen in the test page, it works fine in other pages. I tried overwriting your homepage with template i used on test page but that still did not help.

    Best regards,
    Yigit

    #779526

    Hi,
    About your last answer : if it was a problem of a plugin wich add code, why would it work on the french homepage ?
    Nevertheless, I tried to deactivate each plugin, but the problem remains…
    Oli

    #780481

    Hi,

    Can you please post FTP logins here privately as well? There are two empty div tags on your English homepage, trying to find where they come from and we will need FTP logins to look further into it

    Best regards,
    Yigit

    #780562

    Hi,

    no sorry, there’s no access to the server from outer networks…
    Is there another solution to help you find the solution ?

    Best regards,
    Oli

    #780577

    Hi,

    Can you please try enabling debugging mode – http://kriesi.at/documentation/enfold/ (Purchase code hidden if logged out) /? Functions.php file is not writable on WP dashboard that is why i could not add the code there

    Best regards,
    Yigit

    #780595

    It’s done.

    I’ve added :
    //set builder mode to debug
    add_action(‘avia_builder_mode’, “builder_set_debug”);
    function builder_set_debug()
    {
    return “debug”;
    }
    if(isset($avia_config[‘use_child_theme_functions_only’])) return;

    #780600

    Hi,

    Can you please add following code only

    //set builder mode to debug
    add_action('avia_builder_mode', "builder_set_debug");
    function builder_set_debug()
    {
    	return "debug";
    }

    Right below following line near top

    if(isset($avia_config['use_child_theme_functions_only'])) return;

    Best regards,
    Yigit

    #780609

    Sorry, it’s OK now.

    Regards,
    Oli

    #780612

    Hey Oli,

    Sorry it is still wrong. Can you please replace content of functions.php file with this one – https://pastebin.com/2jhV62a5

    Best regards,
    Yigit

    #780623

    It’s done!

    #781119

    Hi,
    when I valid the HTML code, there are some unclosed div elements and these errors disappear when I delete the layerslider element (with a full width footer!) but on the other hand, the main content is full width too… Weird..

    Maybe it could help you…

    Thanks for help.
    Oli

    #782797

    Hi Oli,

    Do you still need help with this issue?

    If you need further assistance please let us know.
    Best regards,
    Victoria

    #782803

    Hi Victoria,
    yes, definitely, the problem is still here…
    Thanks,
    Oli

    #783884

    Hi,
    is there anybody who could answer me ?
    I’ll put back soon my original functions.php file.
    Best regards,
    Oli

    #783891

    well first of all – the whole Enfold Options Dialog has got his own settings for each flag on top.
    Did you really have all your settings synchronized? f.e. you can have your own quick css for each language.

    By the way if i had to install a multilingual Site i allways do all the Settings for the main language after i’m happy with that – i export the theme settings file – switch the language on top of Enfold Options Dialog by choosing the other flags – and import the main language Theme-Settings file.

    #783893

    1) And now i see you are using a caching tool (autoptimize codes are seen in css etc) are you shure to empty both cache?

    2) And next difference is that your french site got a grid row element above the footer the english version not. Is that footer width different if you have on english Version too a grid-row element above the footer?

    3) all your footer scripts are missing on english version now? !

    • This reply was modified 1 year, 4 months ago by  Guenni007.
    #783905

    Hi,
    Did you really have all your settings synchronized?
    => Yes! (BTW, Yigit must have checked it with the admin. credentials)

    And now i see you are using a caching tool (autoptimize codes are seen in css etc) are you shure to empty both cache?
    => Yes! Both autoptimize and WP super cache.

    And next difference is that your french site got a grid row element above the footer the english version not. Is that footer width different if you have on english Version too a grid-row element above the footer?
    => With a grid row on the english, the footer is OK (full width), but it did not answer the question why it’s not OK without the grid row element…

    • This reply was modified 1 year, 4 months ago by  Oli.
    #783942

    yes that is true but we have to be a bit like Sherlock :lol

    Lorsque vous avez éliminé l’impossible, ce qui reste, si improbable soit-il, est nécessairement la vérité.

    Once you eliminate the impossible, whatever remains, no matter how improbable, must be the truth.

    So my first view was : what is different –
    second view : what could be the reason for differences between english and french version. (so a different cache status could be one reason)

    what is the thing with the scripts missing on english version? (look to the screenshot of source code)

    #783945

    why are the scripts not before body tag closes on english version but they are in main container:
    (by default they should be out of wrap-all container!

    click to enlarge:

    Something like this could happen if you are in debug mode and try to edit or delete something within that debug code.
    By dooing this there are a lot of possibilities to erase something incomplete ( closing tags etc.)

    #784002

    my advice is – erase the page in english. open the page in original language and duplicate the page by using WPML window on top right position
    click the image to enlarge:

    then go and translate your content for each alb element.
    If you don’t like the grid-row element for the english translation – erase it via advanced layout builder (not via debug window)

    #784398

    Hi,

    I think Yigit already try to duplicate french content and then translate it, do you confirm it and do you confirm it will work ?

    Regards,
    Oli

Viewing 30 posts - 1 through 30 (of 33 total)

You must be logged in to reply to this topic.