Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #913830

    Here is the error message I am getting Please help!

    Fatal error: Uncaught Error: Function name must be a string in /home/agilit10/public_html/easytospot.com/wp-content/themes/broadscope/framework/php/class-htmlhelper.php:79 Stack trace: #0 /home/agilit10/public_html/easytospot.com/wp-content/themes/broadscope/framework/php/class-adminpages.php(204): avia_htmlhelper->render_single_element(Array) #1 /home/agilit10/public_html/easytospot.com/wp-includes/class-wp-hook.php(286): avia_adminpages->render_page(”) #2 /home/agilit10/public_html/easytospot.com/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(”, Array) #3 /home/agilit10/public_html/easytospot.com/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #4 /home/agilit10/public_html/easytospot.com/wp-admin/admin.php(224): do_action(‘toplevel_page_a…’) #5 {main} thrown in /home/agilit10/public_html/easytospot.com/wp-content/themes/broadscope/framework/php/class-htmlhelper.php on line 79

    #913859

    Hey etsjules,

    Can you reach that file via ftp and replace the whole function render_single_element with this

    
    	function render_single_element( $element )
    		{
    			if( method_exists( $this, $element['type']) && is_string($element['type']) )
    			{
    				//init indices that are not set yet to prevent php notice
    				if( !isset( $element['id'] ) ) 	  { $element['id'] = ""; 	}
    				if( !isset( $element['class'] ) ) { $element['class'] = ""; }
    				if( !isset( $element['desc']  ) ) { $element['desc']  = ""; }
    				if( !isset( $element['name']  ) ) { $element['name']  = ""; }
    				if( !isset( $element['label'] ) ) { $element['label'] = ""; }
    				if( !isset( $element['std'] ) )   { $element['std'] = ""; }
    			
    				//start rendering
    				$output = "";
    				
    				//check if we should only render the element itself or description as well
    				if(isset($element['nodescription']) && $element['nodescription'] != "")
    				{
    					$output .= $this->{$element['type']}( $element );
    				}
    				else
    				{
    					$output .= $this->section_start( $element );
    					$output .= $this->description( $element );
    					$output .= $this->{$element['type']}( $element );
    					$output .= $this->section_end( $element );
    				}
    				
    				
    				return $output;
    			}
    		}
    

    If you need further assistance please let us know.
    Best regards,
    Victoria

    #913870

    Hi Victoria,
    I don’t know how to do this. Should I hire a website fixer?
    Please advise.
    Thank you
    ~jules

    #913953

    Hi,

    Can you give us ftp access? we’ll try to check it for you.

    Best regards,
    Nikko

    #913981

    Thank you, I appreciate you looking at this.
    Info below.
    ~jules

    #913982

    sorry tyoed below wrong

    #914078

    Hi,

    Thanks, can you also provide the ftp username and password?

    Best regards,
    Nikko

    #914165

    Hi Nikko,
    below is all the info you need. I think :)

    Thank you
    ~jules

    #914313

    Hi jules,

    I get “login failed”. Can you please check credentials?
    Which version of php are you running?

    Actually, I was able to add the code via Editor and it seems to be working now.

    Best regards,
    Victoria

    • This reply was modified 4 months ago by  Victoria.
    #914731

    Ok I think we have it now. The hosting company tested the ftp login
    Info below.
    Please note. I have since messed up my other website the same way, by updating the WP and adding the plugin for instagram. Deleting the plugin did not fix the problem. The plugin support told me to change themes.I don’t want to change themes.
    Can you recommend a plug in that these themes like to upload/.syn my instagram accounts?
    Thank you for your help.
    ~jules

    #914737

    I just went and checked Easytospot.com and it is up and running!!!!
    Now I will go and check daneens.com

    Thank you if you were the big fix!!!
    ~jules

    #914738

    Hi jules,

    I think Victoria fixed it for you. Glad that it’s fixed. Let us know if you need further assistance :)

    Best regards,
    Nikko

    #914739

    Daneens.com is not working.
    This is the cleancut theme
    Thank you
    ~jules

    #914740

    Thank you Victoria!!!!
    Can you do the same thing to Daneens.com??

    #915174

    Hi,

    We would like to check the site but the login credentials above are invalid. Please check it carefully.

    Best regards,
    Ismael

    #915327

    Please try again as the tech support tried it with this info and they were able to get in.
    Thank you
    ~jules

    #915886

    Hi jules,

    Can you please give us WordPress credentials as well?

    Best regards,
    Victoria

    #915888

    Yes, of course, sorry
    :)
    ~jules

    #916030

    Hi jules,

    Can you please explain what is the issue with this website? It seems to be working fine.

    Best regards,
    Victoria

    #916169

    Hi Victoria,
    Seems this theme showed the error differently. I have included a screenshot. hmmm can’t send a screenshot. so if you into my pages, instagram-draft and look at the post thumbnail options you will see this:Fatal error:
    A million thank yous!!
    ~jules

    #916823

    Hi,

    What php Version you have on the server?
    The issue seems to be on that, can you please check for us?

    Best regards,
    Basilis

Viewing 21 posts - 1 through 21 (of 21 total)

You must be logged in to reply to this topic.