Tagged: ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #880973

    Hello guys,

    on my website I got a 500 error on the main page. The Backend worked without any problem. The Theme is up to date. In PHP Error Log I got the following error message:

    [23-Nov-2017 21:43:01 UTC] PHP Warning:  Illegal string offset 'slideshow' in /var/www/wdk50/htdocs/tmmrecords.eu/wp-content/themes/replete/includes/admin/compat.php on line 48
    [23-Nov-2017 21:43:01 UTC] PHP Fatal error:  Uncaught Error: Cannot use string offset as an array in /var/www/wdk50/htdocs/tmmrecords.eu/wp-content/themes/replete/includes/admin/compat.php:48
    Stack trace:
    #0 /var/www/wdk50/htdocs/tmmrecords.eu/wp-includes/class-wp-hook.php(286): avia_backend_compatibility_custom_field_filter('', 539)
    #1 /var/www/wdk50/htdocs/tmmrecords.eu/wp-includes/plugin.php(203): WP_Hook->apply_filters('', Array)
    #2 /var/www/wdk50/htdocs/tmmrecords.eu/wp-content/themes/replete/framework/php/function-set-avia-frontend.php(262): apply_filters('avia_post_meta_...', '', 539)
    #3 /var/www/wdk50/htdocs/tmmrecords.eu/wp-includes/class-wp-hook.php(288): avia_post_meta(Object(WP_Post))
    #4 /var/www/wdk50/htdocs/tmmrecords.eu/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters('', Array)
    #5 /var/www/wdk50/htdocs/tmmrecords.eu/wp-includes/plugin.php(515): WP_Hook->do_action(Array)
    #6 /var/www/wdk50/htdocs/tmmrecords.eu/wp-includes/class-wp-query.php(4038): do_action_ref_array('the_post', Array)
    #7 /var/www/wdk50/htdocs/tmmrecords.eu/wp-in in /var/www/wdk50/htdocs/tmmrecords.eu/wp-content/themes/replete/includes/admin/compat.php on line 48

    The fix for this error can be found here:
    wp-content/themes/replete/includes/admin/compat.php:46

    Change:

    if(empty($custom_fields))
    {
    	xxx
    }

    to

    if(!empty($custom_fields))
    {
    	xxx
    }

    (there is a ! before the empty)

    Can you fix this in the next version?

    #881020

    Hey WebdesignKronberg,

    Thanks for your feedback! We are glad that your problem was solved.

    Best regards,
    John Torvik

    #1036062

    THANKS WebdesignKronberg, you saved my day!
    Seems to be normal if one is running Replete and WooCommerce latest versions if the website is set up according actual WP requirements (i.e. PHP 7.2!).
    I am curious what surprises await us with the next version of WP (WP 5.x).
    The Replete Theme urgently needs to be updated!

    Cheers,
    Heike

    #1037199

    Hey Heike,

    I’m glad this was resolved for you. If you need additional help, please let us know here in the forums.

    Best regards,
    Jordan Shannon

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Error on page display’ is closed to new replies.