Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
  • #17033

    Hello Kreisi,

    I am geting “Error 404 – page not found” on all pages except the home page when using your Propulsion theme.

    I allready try to:

    – “flush” permalinks. It does not help.

    – change permalink structure to one of your recomendation “/%category%/%postname%/”. It does not help.

    If I change permalink structure to “default” (http://localhost/abc/?p=123) everything works. But I really need the “pretty” permalink structure.

    I’m using:

    – WP 3.4.2

    WPML 2.6.0

    – WP is installed in subdirectory

    Best regards and thanks for your help.


    Hi dasBIOS,

    Check the permission of your .htaccess file. It might be that WordPress isn’t permitted to change anything on your .htaccess file. Also try to check Settings > Permalinks and look at the bottom of the page you might see some text like this:

    If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.

    Below it is the code you should paste in your .htaccess file.




    WP can write to .htaccess.

    There is no message at the Settings > Permalinks.

    I also manually delete the content of the .htaccess and recreated it’s content from Settings > Permalinks > “Save Changes”.

    The .htaccess is re-filled.

    It didn’t helped.

    What should I do next?

    Best regards.


    Anything new?


    Hi dasBIOS,

    Are you using XAMPP, WAMP or other local webserver? If you are using XAMPP this link might help: (Purchase code hidden if logged out) -in-xampp-setup/




    Yes, I’m using WAMP/XAMPP dev/test environment,

    I double checked the configuration and it is as is stated in your link.

    I’m also running quite a lot of other test/dev sites on that XAMPP installation – without any problems.

    I set up the separate “pure” LAMP test environment.

    There is the same problem.

    Would it help if I send you the WP access information from the test site?

    Best regards.


    Hi dasBIOS,

    Maybe it can help. But as of the moment, I can’t think of any other solution. Let me tag the rest of the support to check this issue.




    Hi dasBIOS,

    The only other thing I can suggest is to go through the basic troubleshooting from the wordpress codex for permalinks:

    If you want to see if this is specifically theme related, change the theme you are using one of the default wordpress themes and give your page links a test with the various structures. If it is somehow a theme issue we can help, otherwise I’m not sure what other routes we have to help.





    Sometimes I experience similar events though not yet with Kristie’s themes. I think this is a WordPress core issue. Delete the database. Please try to use the xampp install from . I usually had good results with them.

    Don’t forget to set the 8 keys and salts in the wp-config file. Does your windows account have privileges for the directory you are working in?

    Please try to re-install the xampp directory away from the recommended location. I always put mine on my spare hard drive. Please let us know how it went.

    Also try to stay away from using localhost. Instead create an alias since a number of plugins expect a domain name that has a format of which localhost doesn’t follow. I use as my localhost and then sub-domain it for different installs. etc…




    Hm… OK.

    My WAMP (XAMPP, localhost) and LAMP (domain) dev environment are behaving identical.

    Only now I noticed that only Pages (!?) are returning 404. Everything else is OK (posts,…).

    I turned off all plugins and everything is working.

    Then I systematically turned on/off all the plugins and I manage to micro locate the plugin that is causing the 404 on pages: WPML Multilingual CMS 2.6.0.

    That test was made on the LAMP (domain/non localhost). With WP 3.4.2.

    Isn’t the Propulsion theme compatible with WPML?

    Best regards.



    Please install the additional WPML plugins (wpml-string-translation , which you can download from the same area you downloaded your WPML plugin) and also download and installed the wpml_multilingual_compatibility_testing tool plugin. Run the string translation. Then run every test on the testing tool. Everything should start working fine.

    [EDIT] Also , how are you setting up WPML translation as a directory, a subdomain or a query string?

    Please let us know,





    Hi Nick,

    I tried as you described. It didn’t work. I still have the same problem.

    WPML translation is setup as “Different languages in directories”.

    Best regards





    I just reinstalled the theme on my desktop xampp, added the plugins, and translated a page. I also received a 404 error for both english and the translation language. So I followed my previous directions and scanned the theme for strings. It took less than a minute to scan the theme and about 15 minutes to scan plugins (during which time i did not leave the page where i started the scan.) When it finished, I went to permalinks page and changed them once, saved, changed them back to ‘Post Name’ and saved and both of the pages that previously did not work, began instantly working.

    Here is what my settings looked like , (this is where took 15 minutes)





    thank you for helping me.

    I tried again and it didn’t work (Propulsion theme was activated).

    To make it “work” I had to switch to the Twenty Eleven theme there repeat your procedure and then switch back to Propulsion theme.

    But your solution cause the following problem:

    After following your steps, my (before working) custom post type stopped working with the same message as before for the pages “Error 404 – page not found”.

    Is there something specific to setup when registering/using custom post types with Propulsion theme?

    I really need the custom post types in my project.

    Best regards.


    I think I found the solution:

    At the end of the functions where custom taxonomy/post type is defined I temporary added:

    flush_rewrite_rules( false );

    Refreshed the page and everything started to work. :)

    Then I commented out the line (it needs to be run just once & it’s quite expensive to run it on every page all the time).

    Hm… maybe it would be the best to include/run it on theme activation hook, that way it would be automatically run just once (when the theme is activated).

    function onThemeActivation($oldname, $oldtheme=false) {


    //Custom post & taxonomy slug FIX


    flush_rewrite_rules( false );


    add_action(“after_switch_theme”, “onThemeActivation”, 10 , 2);

    Thank you all for your help!

    Best regards.

    PS: Is it possible to somehow sign to topic so I ould receive the updates on email?


    The above solution also solve my initial problem.

Viewing 16 posts - 1 through 16 (of 16 total)

The topic ‘Error 404 – page not found’ is closed to new replies.