Viewing 28 posts - 1 through 28 (of 28 total)
  • Author
    Posts
  • #855635

    Hi,

    I am getting the error message “Could not connect to Google Maps with this API Key.” I registered to get a Google Maps Api key however it’s giving me an error message after clicking the “Check API Key” button.

    I followed your tutorial http://kriesi.at/documentation/enfold/ (Purchase code hidden if logged out) -maps-api-key/ and still no luck. I can provide my credential if necessary.

    Please advise – thanks,
    Louella

    #855915

    Hey louella-NBY,
    Can you please include a admin login in the private content area, with FTP access, so we can take a closer look. Also your API Key.

    Best regards,
    Mike

    #856700
    This reply has been marked as private.
    #856912

    Hi Louella,

    Please try to generate the key again.

    Best regards,
    Victoria

    #857121
    This reply has been marked as private.
    #857580

    Hi Louella,

    What domains did you authorize? The error in private.

    Best regards,
    Victoria

    #857684
    This reply has been marked as private.
    #858052

    Hi Louella,

    YOu don’t have a “.” here http://neutrophase.staging.wpengine.com/. (hosted on WPengine) Please change to *neutrophase.com/*

    Best regards,
    Victoria

    #858191

    Yey – thanks Veronica!

    The Google Map is loading now https://imgur.com/a/pgxGw (http://neutrophase.staging.wpengine.com/contact/). (hosted on WPengine)

    I changed to *neutrophase.com/*’ and set the ‘Key Restrictions’ to None – it works! Is it safe to set to ‘None’?

    Thanks for all your help,
    Louella

    #858773

    Hi,
    Normally “none” should be fine, there are four types of API key restrictions are available:
    Server restriction (by IP address) – for use with the web service APIs.
    Browser restriction (by HTTP referrers) – for use with the Web APIs.
    Android app restriction (by package name and fingerprint) – for use with the Android APIs.
    iOS app restriction (by iOS bundle identifier) – for use with the iOS APIs.
    read more here: https://developers.google.com/maps/faq

    Best regards,
    Mike

    #859385

    Thank you for confirming, Mike.

    #859438

    Hi,

    Glad that Mike helped you. Let us know if you need more assistance :)

    Best regards,
    Nikko

    #984242

    Hello,
    For some reason I can’t get the Google maps key working…

    Ive tried everything below…
    – Check if you typed the key correctly.
    – If you use the restriction setting on Google try to remove that, wait a few minutes for google to apply your changes and then check again if the key works here. If it does, you probably have a syntax error in your referrer url
    – If none of this helps: deactivate all plugins and then check if the API works by using the button above. If thats the case then one of your plugins is interfering.

    Hope you can help to figure out what’s going wrong.

    Thanks!

    #984428

    Hi,
    I took a look at your site and found there was no map api key in: Enfold Theme Options > Google Services > Google Maps API
    so I tried entering the api key, but got this error: “Could not connect to Google Maps with this API Key.”
    Please try checking this key, or creating a new key with no restrictions to test.

    Best regards,
    Mike

    #988424

    Hi there, having the same problem.

    Only very recently jumped through all the hoops to create a Google Maps API key for this new project and it worked. Now, that I’m actually trying to use a map enabled plugin for the first time, Enfold says that it cannot connect to the API key. There are no restrictions whatsoever associated with this key; hence, it’s simply beyond what Google is taking issue with now. Google makes my blood boil.

    Would you mind taking a look? I’d really appreciate it.

    Many thanks.

    #988433

    Hi,
    @MadRhino we would be happy to take a look, but please open a new thread so we can assist, and include your admin login in the Private Content area, but as this is not your thread your login info will not be private here

    Best regards,
    Mike

    #988653

    Hi Mike,

    I have tried everything suggested. Also contacted my hosting and they said gate 80 and 443 are open so there should not be any problem from their side.

    But I am still having an error on my google maps showing for 2 weeks nog… I wonder if it has anything to do with they key that I got from Google. Anyway you can try a key from a different (older) account? Or any other ideas that I could try?

    #988656

    Hey everybody,

    I just wanted to share with you that although I’m still receiving an error message in Enfold in connection with Google’s API, entering it directly in the plugin has actually fixed the problem for me and everything is working fine now.

    So, in case you are having problems with a plugin, rather than Enfold’s built-in Google Map tool, maybe you want to try this.

    #988850

    Hi MadRhino,

    Thank you for sharing.

    Glad you got it working for you! :)

    If you need further assistance please let us know.

    Best regards,
    Victoria

    #988905

    Maybe you can help me Victoria?

    #988985

    Hi,

    Is it a new account? Have you enabled Billing? Or else the maps will give you an error.

    I checked your site with my API key and it works fine.

    (Screenshot attached)

    Your maps work fine too…

    (Screenshot attached)

    Please follow the steps mentioned in the documentation. Create a new project and API key and try again.

    Best regards,
    Vinay

    #989208

    Hi Vinay,

    Thanks! I still had to verify my bankaccount number…. thought it would already work… as they gave me a key.

    Now it works.

    Regards Patrick

    #989576

    Hi CTBanners,

    Glad that Vinay helped you :)
    Thanks for using Enfold and have a great day!

    Best regards,
    Nikko

    #998673
    This reply has been marked as private.
    #998771

    Hi thi2109,

    Can you please post your key in private?

    Best regards,
    Victoria

    #1019921

    also i have this error , how to fix that

    #1019965

    Hello,
    I had fixed the issue before. Now I do connect throught the template to the Google Maps API but get an error when I try to fetch coordinates.

    An error occurredX
    Too many requests at once, please wait a few seconds before requesting coordinates again

    Any idea what could be causing this?

    #1020592

    Hi,
    This was recently resolved by another user by setting up their billing info
    If that doesn’t help, (Purchase code hidden if logged out)(Purchase code hidden if logged out) /”>please see this post

    Best regards,
    Mike

Viewing 28 posts - 1 through 28 (of 28 total)

You must be logged in to reply to this topic.