Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts
  • #1023073

    Support team,
    I have read many of the threads that have been posted about issues with the 4.5 ver update. I installed the “Update Theme and Plugins from Zip File” and it did not help — threw a “The package could not be installed. The theme is missing the style.css stylesheet” error.

    Question — will Themeforest address their API issues? If so, when? I am hesitant to go into all of my sites via FTP, because I do not want to make a “fatal error”. Is there another fix in the works?

    I will stay with ver 4.1.1 until I hear that Themeforest and/or Kriesi have a better solution. Love your theme, but this is crazy! Themeforest should step up and take care of business! 😀

    Cheers!

    • This topic was modified 9 months ago by  jancecile.
    #1023115

    Hey jancecile,

    The error you are getting is mostly due to uploading the wrong format Please check the below link to resolve it
    https://kriesi.at/documentation/enfold/ (Purchase code hidden if logged out) /#missing-style-sheet-error

    To register your theme using the new Envato Personal Token please check
    https://kriesi.at/documentation/enfold/ (Purchase code hidden if logged out) /#theme-registration

    I assure you the latest version Enfold 4.5 is more stable and secure. Please go ahead and update your theme.
    https://kriesi.at/documentation/enfold/ (Purchase code hidden if logged out) /#theme-install

    In case if you have any issue our support team is here 24/7 to help you :)

    Best regards,
    Vinay

    #1023524

    This is what I got after creating a new API”

    Last time we checked the token we were not able to connected to Envato:

    Purchases could not be accessed
    Username could not be accessed (needed for your information only)
    E-Mail could not be accessed (needed for your information only)
    Following errors occured:

    Purchases: Errorcode 403 returned by Envato: Forbidden
    username Errorcode 403 returned by Envato: Forbidden
    email Errorcode 403 returned by Envato: Forbidden
    Purchases: A problem occured accessing your purchases. Unable to check for updates.

    #1023999
    #1025202

    Hey Vinay,

    Once again you all have come to my rescue! It was updating the token — strange process, but all is good on the first site. Will let you know if that changes as I proceed with additional updates tomorrow. Note: in Themeforest, it refers to “APP” not theme — but they are, for their purposes, one in the same 😀 — at least I think that’s correct…

    Thanks to the Enfold support TEAM!

    Cheers!

    #1025429

    Hi jancecile,

    Glad to hear that :)
    Feel free to comeback if you need further assistance.

    Best regards,
    Nikko

    #1027792

    Having issues upgrading to 4.5 again.

    This site is using the Enfold theme — the same copy that I use for my website. Tried using the same personal token from Themeforest. It will not allow the update. Created a new personal token, that did not work.

    Tried uploading .zip file of 4.5 and it gave me the same “The package could not be installed. The theme is missing the style.css stylesheet” error.

    Have tried to manually install to get the connection to the 4.5 update, and it can’t find it.

    I also tried running the “Transient Cleaner” plugin — it did not find any issues, so it too did not work.

    PLEASE don’t tell me I need to install via cPanel to server @ host! Makes me VERY nervous when I have to go to the “brains” — I know just enough to get myself in trouble.

    Is there a fix in the works for this? I don’t want to bill clients for all of the extra time to do all the fixes. Just doesn’t seem right to bill them for time that Themeforest should have taken into consideration before they “updated” the process. Can we go back to how it was before??

    Looking forward to your quick reply!

    Cheers!

    #1027815

    I was able to update to Enfold 4.5 on my staging site, but now the Enfold Child shows up in Broken Themes on the Themes page.
    My thread is here, but the responses have been a little slow.
    (Purchase code hidden if logged out) -enfold-child/”>Enfold 4.5 Update – Problem Enfold Child

    Best solution?

    #1027846

    Hi,
    @classywebsites I replied in your thread.

    Best regards,
    Mike

    #1027849

    Hi,
    @jancecile
    Please include a admin login & FTP access in the Private Content area, I will assist.
    I believe the reason you got the “The package could not be installed. The theme is missing the style.css stylesheet”
    error is because the zip file has the theme inside another folder.

    Best regards,
    Mike

    #1027944

    I must admit I am very disappointed by this answer. I am not upset that there are problems, I am however very surprised by your intended solution.

    This whole issue is your problem – stop making it mine!

    How is every other theme producer dealing with Theme Forest changing their API for Token keys? Do they all expect their clients who have paid for a service to manually update or do it via a plugin? I am particularly pissed that you then saw fit to close the topic to new replies without giving me the opportunity to ask any questions.

    As I mentioned I have numerous Enfold sites and freelance as a designer for 2 other agencies that have over the years (at my insistence switched to Enfold). Now you expect me to install a plugin to update x sites, including sites that are being managed by clients? I have no direct access to some of these sites and I talked a few of them into leaving other themes that they were actually happy with – this is not customer service, this is bullshit!

    In your instructions (https://kriesi.at/support/topic/ (Purchase code hidden if logged out) /#post-1027288) you talk of “delete the current enfold folder and then upload the new one” without making it clear if this only applies to a manual ftp update or also to the update via plugin? Is this a problem if I have changed the php of a child theme?

    Seriously, if I install this plugin, do the update and there are problems, what solution do you suggest then?

    Charl

    #1027945

    The above comment is relating to the our previous discourse https://kriesi.at/support/topic/ (Purchase code hidden if logged out) /#post-1027578

    #1027998

    Hi Mike,

    I went back to my thread with a question. I’ll stop posting in this thread if you can please continue responding in my thread. Thank you!

    #1028016

    Hi,
    @classywebsites
    I believe we cross posted – I just finished solving your issue, I will look for your reply in your thread.

    Best regards,
    Mike

    #1028315

    Hi Mike,

    Sorry, but no. The zip file I tried to upload is by itself — not in a folder with ll of the other documentation. It has updated fine with accounts that have their own Themeforest account. Can you confirm (or not) that issue might be because the token being used is a part of my personal account, and not unique to the client’s account? Might be that Themeforest has abandoned their willingness to have 2-3 sites use the Enfold theme from one account. Would be a reason why they have introduced this “bizarre” token system.

    Thanks for any insight you can give — and again, the .zip file I tried to upload is a stand alone .zip, designated with Enfold info in the file name.

    Cheers!

    #1028331

    Hi,
    @jancecile
    Please include a admin login & FTP access in the Private Content area so we can try to update for you, and allow us to see the error.
    I don’t know why Theme Forest has created the token system.

    Best regards,
    Mike

    #1028667

    Hi Mike,
    The error message is as I posted in my first post above — “The package could not be installed. The theme is missing the style.css stylesheet”

    I’m not asking “why” Themeforest has gone to a new token system. I am asking if with the new tokens, users are no longer allowed to use your theme in more than one website per account. I have some sites that have their own Themeforest account and after using the new token, all goes well.

    Do you understand?

    Any help is most appreciated!

    Thanks,

    #1028668

    Okay! So now the auto update from the theme, even with the new token from a account that has purchased the theme — is not working.

    Unpacked the zip file to enfold.zip and I get this message … also happens when I try to upload (Purchase code hidden if logged out) -theme-wordpress-theme.zip

    Unpacking the package…
    Installing the theme…
    Destination folder already exists. /home4/*siteowner*/public_html/wp-content/themes/enfold/
    Theme installation failed.

    What? Please help. Why has it become so difficult to do this update? It was so smooth before this. Why change something that was working just fine?

    PLEASE HELP!
    😀
    ———–
    OKAY, 60 minutes later … I installed the “Update Theme and Plugins from Zip File” plugin. Uploaded 4.5 using the ” (Purchase code hidden if logged out) -theme-wordpress-theme.zip” … it worked. Update page in the Enfold window in WP also made note of the API changing to tokens — put the newly created token in the space provided. Saved. Checked the Appearance tab and Enfold, it is 4.5. Logged out. All looks good.

    Question — does the plugin need to stay? Can I deactivate it or remove entirely? I like to keep as few plugins as possible on my sites.

    All is better … be at peace, there is way to much craziness in the world, lets not bring it here. Everyone step back, and take a nice long breath. Wellness to all 😀

    • This reply was modified 8 months, 2 weeks ago by  jancecile.
    #1028685

    Hi,
    Glad to hear all is well, you can remove the “Update Theme and Plugins from Zip File” plugin, it was only needed this time, going forward the theme will update as in the past.

    As far as I know there has been no change in licensing by Theme Forest. If you question this please login to your Theme Forest account and ask their support, because we have no licensing documentation here, we always refer to Theme Forest on that topic, as we are tech support.

    Thanks for your patience and understanding, and for using Enfold.

    Best regards,
    Mike

Viewing 19 posts - 1 through 19 (of 19 total)

You must be logged in to reply to this topic.