Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #17671

    Hi there, I want to create custom page titles site wide. Have managed this for all the non woo commerce pages – using either the Yoast wp seo plugin or WP Title 2. With both of these I am able to create custom titles for the woo commerce pages, but these new titles don’t show up in the browser window. The main one really is the shop page. At the moment the web address is

    And the default title is Product Archive.

    I would like the web address to be and the title to be “catalogue of autographs and historical documents”

    In the woo commerce settings I have changed the name of the page to “catalogue”. And using either of the plugins, input the following for the title:

    “catalogue of autographs and historical documents”.

    But I cannot seem to shift the default titles showing in the browser.

    Any ideas what could be causing the problem?

    Many thanks,




    You need to replace following line in header.php:

    <title><?php bloginfo('name'); ?> | <?php is_home() ? bloginfo('description') : wp_title(''); ?></title>


    <title><?php wp_title(''); ?></title>

    Best regards,



    hmm, have tried that but no difference. Any other suggestions gratefully received! Susan


    Hi Susan,

    Try giving the page a hard refresh to clear your local cache. Other than this, there is nothing else within the theme that effects the page title attribute.




    hey susan, I see you fix that error in your website. About title in shop page with yoast… how you fixed?



    Hi albertorrent,

    I believe you need to add the settings somewhere inside Yoast. Having not used it I can’t say for sure where it is, but I know others have mentioned its in the main yoast settings.



Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘custom page titles not showing on shop pages’ is closed to new replies.