Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
  • #7936

    Happy new year!

    When I activate cufon, the menu links won’t hover >

    If I make the header fonts Arial, the hover works fine.

    Any thoughts on this? Have searched but to no avail…




    Any help would be ace.


    I think this is a css issue and not a cufon issue because Kriesi already uses the cufon hover effect – he added following code to the cufon function call:

    Cufon.replace('.cufon_headings',{  fontFamily: 'cufon', hover:'true' });


    Thanks for your time. Yes I did see that, and have already tested it with custom.css removed in it’s original format. I noticed that other sites also don’t hover >

    Have you tested your untouched version to see if it hovers with cufon?



    Please try to add following code to css/cstom.css and change the color value:

    .main_menu .menu a:hover {
    color: #ff0000;


    It didn’t make any difference. The hover works fine with standard fonts (not cufon)


    Strange. I’ll ask Kriesi if he’s aware of an problem with Cufon.


    Hi, I have installed a new version of wordpress and your theme, and it seems that cufon won’t hover from scratch. Please can you advise.




    Dude? Any news on the hover problem?


    I’m having the same hover issue with all the Cufon. Of course it’s especially bad on the inert main menu. On one of my pages, where a list of links is in H2 Cufon font, I tried giving it an underline just to signify that the words were links. That did not take either. I’ve tried all the various css changes listed on this thread and in the forums, none made a difference. I’d hate to go back to Arial—any chance that this Cufon hover issue can be fixed? Thanks for letting us know…


    hello – having the same problem – with Flashlight 1.7 (WP 3.4.1) – any solution in sight?)


    Hi nasch,

    I believe this was fixed in version 1.6. Do you have a link to your site so we can see whats happening and inspect the code a bit?




    hi devin

    sure – here it is:

    it works fine as long as under ‘Heading Font’ > ‘no custom font’ is activated



    Hi nasch,

    In your Theme Options>Styling try selecting a color other than #555 for the option “Secondary Color”. If that doesn’t work for you, try disabling qtranslate and see if that resolves it.

    If you look at the demo, the menu is using a cufon font and has the hover effect still intact so its a matter of pinpointing what in your installation is causing it not to work correctly.





    in Theme Options>Styling there is a pink (#ff00c4) selected.

    And it does’nt seem to be the qtranslate plugin either which

    is deactivated right now.

    It happened right away after installing the Theme with the demo

    content and nothing changed by switching to any of the Heading

    Fonts under Flashlight>Styling>Heading Fonts.

    Quite confusing – i see it working with you demo – in the same




    hello – update:

    i just checked changing the font in your demo by ‘change styles>heading font’ on the right side menu and the rollover doesn’t work in the demo either..

    any suggestions?



    Hi nasch,

    Let me tag this issue for Kriesi as I see what you mean in the demo and in the most recent version on my local install I’m having similar issues.



Viewing 17 posts - 1 through 17 (of 17 total)

The topic ‘Cufon hover not working with Flashlight’ is closed to new replies.