Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #16356

    Hi there,

    I configured the “Contact” page to send messages to my own email address ” (Email address hidden if logged out) “.

    here is the link:

    the web site is in Arabic, and i set the encoding of “/includes/contact-form.php” to UTF-8

    still the messages never received.

    I contacted the web hosting company & contacted Google Apps while the email is configured in their services. Both confirm that the problem is in the PHP script.

    please help me to fix this issue.


    – Khaled



    Not sure about having a problem with the PHP script of the Choices contact form because I tried it on my test site and it works fine. Please try another plugin like Contact Form 7 for the meantime.




    I tried Contact Form 7 and it works fine. Can’t we fix the Choices contact form?


    Hi Khaled,

    I’m tagging Kriesi to this thread so he can review.




    waiting :(


    Hi Khaled_288,

    Strange, both contact forms use the wp_mail function which runs it through wordpress. I’m not sure what would cause it to work with the plugin and not with the built in contact form.

    Did you try using the contact form without any modification the the contact-form.php?




    I restored the original file (contact-form.php), and the problem is still there. is there anything wrong in the AJAX stuff? somthing in the encoding?



    Please install this plugin which will test if there is an issue with email itself. Its old but still does its job.

    You can also try installing this plugin and afterwords please check if mail is coming in.





    The first plugin (check-email) is working find and send emails correctly.

    The second plugin (wp-mail-smtp) has two options:

    when I choose Mailer:

    – Send all WordPress emails via SMTP. it does not work and emails are not being sent.

    and when I change the option to:

    – Use the PHP mail() function to send emails. works fine and emails sent correctly.

    I think your plugin is not using the PHP mail(). is there anyway to configure that?



    Kriesi’s form/send code already uses the standard php mail function. The code can be found in choicesframeworkphpclass-form-generator.php – search for following two lines:

    mail($to, $subject, $message, $header);

    and for the autoresponder:

    mail($from, $this->form_paramas['autoresponder_subject'], $message, $header);


    thank you very much .. so what is the problem .. I could not figure it out :(



    Your form doesn’t have input id, and names fields correctly set, thus the mail never gets sent. What I think is happening is that the input fields have an English avia_ prefix at which point the Arabic suffix attempts to attach and for whatever reason that doesn’t seem to work.

    Here is an image of how your code looks live ( ) and this is how the demo site looks ( )

    What’s interesting is that the user name itself is in English (the field) so the hidden field carries over without a problem. Is the WordPress backend in Arabic? I think if language is kept consistent in those fields which visitors won’t see, that will solve the problem.

    [Edit] Now that I took a further look, Perhaps you could look in Choices > Theme Options > Contact and see if you have a value set for the Labels field, one for each form element, because I don’t see any on the form itself as I fill it out. I think those labels are actually the variable name that gets attached to the prefix. Would you set the Labels please in the Theme Options, and we can always make them not display with css.





    The problem with the form is that it applies input IDs based on sanitized names.

    for example if you got 3 input fields named: Name, Email and Message the theme tries to create valid ids by those names and converts them to avia_name, avia_email and avia_message.

    Problem in your case is that your language will get filtered out compeltly because avia_الرسالة is not a valid id. I have modified the framework to work better with your language, the next theme update tomorrow should fix the issue.

    Best regards

Viewing 13 posts - 1 through 13 (of 13 total)

The topic ‘Contact form is not working’ is closed to new replies.