Viewing 30 posts - 1 through 30 (of 38 total)
  • Author
  • #21460

    After uploading the upgrade to 1.9, the front page won’t show the callout style message on the front page.

    I put the text styling as callout style and filled in the textbox.

    I’ve tried trying different settings and I’ve been going back and forth with my older theme to see what the difference is but I can’t seem to figure it out.

    (I’m also very new to all of this website stuff)

    Thank you


    What I originally had was just the callout text under the line below the logo and the “about us” & “contact” link.

    It did not have “blog-latest news” and search site option nor the section below where it says “nothing found” and the sidebar on the right with the pages, categories and archive. I don’t want any of this to show on my front page.


    Hi estrella88,

    Do you have the frontpage set in the theme options? Does that page then have the dynamic template you want for the frontpage select on that page (the frontpage using the correct frontpage template)?

    Any other information you have on how things are set up would help :)




    I can’t get this to work either no matter what I try. I only have 3 types of templates in the theme builder and I have tried to add callout to all, saved, refreshed and still no luck. I tried on safari and then on chrome too.



    Can you do a snapshot of this because if you are referring to the hero text, it still works for me. Where do you set this?




    Hi Nick, I am talking about the text “Hello and welcome friend! This is propulsion, a responsive business portfolio and eCommerce Theme” found on your demo homepage just under the main menu.

    Thank you.



    Yes, the hero text.

    I am using Propulsion 2.0 and I do not see any of this either by selecting Dynamic element Textarea/Callout/Quotes which has 3 options ( ) inside, and I tested all 3 on the homepage and all 3 work. I used 3 elements: the one i mentioned above, horizontal ruler, and Heading and these were results when I added the dynamic template to the page declared as home in Propulsion > Theme Options:

    Callout Style:


    Blockquote Style:->

    Paragraph Style:—>

    Please upgrade to 2.0 and check your plugins if you are not able to replicate this on your site.




    I have the latest theme upgrade installed and still it does not work. I tried hero text but it just placed it with regular font in the body of my homepage, not in callout area. What can be the cause of this? I have not changed any core code….


    I should add that I used template builder to create my own layout, which I am using a custom PAGE for my homepage.



    Can you post a link to the page where you’re using the hero text? Maybe it’s a css issue and a plugin, etc. overwrites the font-family of the hero text element…

    Best regards,



    Possibly CSS because I notice that it is not taking on the H1 class. But bigger issue aside from CSS is that the position of the hero text or callout is in the body of the page and not above the main slideshow. I think this is a bug with using my own template to create a homepage.

    I don’t have the hero text activated at the moment but here’s the link to it:



    Please update to v2.0 , the latest Propulsion at . You will need to update using ftp which will overwrite your theme files, so make sure to make a backup.

    Is this how your homepage is setup ?

    Actually. Please reinstall wordpress itself. I am seeing a class on your body tag which wordpress removed long ago, so I am not sure why its there. (Purchase code hidden if logged out)(Purchase code hidden if logged out)




    Here’s shot of my homepage setup:

    Not sure why wordpress got tweaked as I did not mess with any core code and never do but I will try this too.

    Also, strange, never received email about updated propulsion. Let me try now, thanks.


    Ok. Updated Propulsion to the latest version, reinstalled WordPress but still not showing the callout. I tried to add hero text exerpt too but it does not show up above slide but in body of page and not using H1 tags.


    Is there a way to use template builder to make a dynamic page template with a sidebar element? Right now there is no element to add sidebar so I am forced to use standard Propulsion theme Right Sidebar layout which is not allowing the Callout. This is an obvious bug in the theme. Can you tell me the code to add Callout to RIGHT SIDEBAR layout?




    You are doing it wrong judging by your settings. I made a video for you outlining the entire process in 3 minutes, just watch what i do, pause and repeat, and you will have yourself a proper callout no faster than in 3.07 minutes .




    Hi Nick, thank you for the video and yes, I have seen it before and have tried this too but when I use Right Sidebar as the Dynamic Page Template Layout, I cannot use Full Width Slider because of the sidebar conflicts with the space (see screenshot). For whatever reason the callout is over the slider too…

    So, I did my method to work around it and still get a right sidebar with full width slider.

    Do you propose any other solution to achieve this?


    Is there a way to duplicate the default Right Sidebar dynamic template page layout and create my own where I can move the Right Sidebar down so it will fall below slideshow?



    The solution I proposed works 100% of the time , thus there is no need for any other.

    Where is the page that you’ve created as I’ve shown in the demo on your site? I can use css to complete whatever else is necessary even if callout is over the slider. The way you are doing it is wrong and my answer is backed up by a lot of experience. Please follow my video or show me page because otherwise this will turn into a prolonged and unnecessarily frustrating experience only to return back to this spot .




    Hi Nick, I understand, thanks. I have thoroughly reviewed and completed tasks per the video. Here is what I get:



    Please add this css to your /css/custom.css file OR to Quick CSS located in Propulsion > Theme Options > Styling Layout … the text area at the bottom of that page.

    #top.home .outer_callout {
    @media only screen and (min-width:768px) and (max-width:959px) {
    #top.home .outer_callout {
    @media only screen and (max-width:767px) {
    #top.home .outer_callout {
    @media only screen and (max-width:479px) {
    #top.home .outer_callout {
    padding: 62px;




    Hello Nick, thank you for this. I have added code to quick css and it has modified the callout but the full width slider is still not working. Please check the site. How can I lower the right sidebar and make slider full width?

    The slider in the dynamic template layout is set to take on the post/pages slider options, which is set to full width but it is not doing so.

    Thanks again!



    You mean this ->

    It can be done, but either I can restrict it to the homepage or have this look on every page since anything else would be too time consuming on my end.

    The callout I will add for you in part 2 once the slider is situated. So..

    1) Please add the following to the very last line of functions.php in the main theme folder:

    function am_i_home9999()
    global $avia_config;
    $body_class = "";
    $thevalu = "";
    $body_class = ob_get_contents();
    $thevalu = (strpos($body_class, 'home') > 0) ? 1 : 0;
    return $thevalu;

    2. Open up /includes/helper-templates.php and look for line 182 that should look like

    if(!isset($element['saved_value'])) return;

    delete the above line, and in its place paste these two lines below

    if(!isset($element['saved_value'])) return;
    if (am_i_home9999()) return;

    3. Open up template-dynamic.php in the main theme folder, and look for line which looks like the line below

    <div class='container'>

    delete the above line and in its place paste the following

    <!-- ####### SLIDESHOW START ####### -->

    $slider = new avia_slideshow(get_the_ID());
    if($slider) echo $slider->display_big();

    <!-- ####### SLIDESHOW END ####### -->

    <div class='container'>

    Just please follow the steps carefully, I tested and it works.




    Okay, done! Looks great! I will have to reupload new slideshow images with small height (as height is way too big right now) but other than that looks good.

    Please continue with how I can add callout above it now, thanks!


    How can I fix the callout Nick?



    Nick, I also tried to upload a smaller slideshow image since it is showing very big on screen. How do you recommend I solve this so image is 100% full width without the zoom and still responsive?



    You need to use wider images of course. Yours are 930px wide and on my screen 1350 laptop it looks fine but on 1900px monitor the book is looking a bit blurry. Get some 1800px wide images. They will shrink automatically for various screen sizes. There is no other way to make a 930px wide image to be full size on a screen size bigger then 930px except to get a wider image. I think though if you cut the height since it blows up to 1904×819 on the big monitor . I think if you get images 1700x 550 you will be ok. You can also using css put a max width that prevent the image from getting any bigger with css like this

    #top .slideshow li img {
    max-width: 1600px

    The simplest thing to do with the callout would be to hard-code it . Just replace the edit you did in header.php with the one below

    $slider = new avia_slideshow(get_the_ID());
    if($slider) {
    echo'<!-- ####### SLIDESHOW START ####### -->';
    echo $slider->display_big();
    echo '<!-- ####### SLIDESHOW END ####### -->';

    <div class="hr hr_invisible dynamic_el_x">
    <div class="outer_callout dynamic_el_x">
    <div class="callout hero-text">
    <div class="content-area">
    The most comprehensive website dedicated to Physique developed by industry experts, trainers, professionals and enthusiasts — like you.
    <div class='container'>




    Great Nick, I will give this a try. So for the callout, if I want to change the wording, I have to go into the code, right?


    Just tried to set the max width of the slider image and it just loads zoomed, than resizes to max-width that is not center aligned. Please see and let me know what you think…



    It will always load ‘zoomed’ since your images are 1/2 as big as the screen. As I wrote before, please use images of full screen size or go back to using the standard slider. Use this css in addition to the previous.

    #top .slideshow_container , #top .slideshow, #top .slideshow li img {
    max-width: 1280px;
    max-height: 551px;
    #top .slideshow_container{
    margin-left: auto;
    margin-right: auto;

    Yes, just change the callout in header.php.



Viewing 30 posts - 1 through 30 (of 38 total)

The topic ‘Callout on Front Page’ is closed to new replies.