Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #14938

    Hey – I’ve got the same problem as user Buitenruimte last month:

    I want to display the blog on my frontpage but also have a link in the menu to the blog. Unfortunately this tdiscussion is closed without offering any solution, so I have to ask this again.

    If I choose to display the blog on the frontpage and additionally in the page “blog”, then the frontpage stays empty and the blog page shows the blog.

    If I leave the field “Frontpage Settings” in Angular Theme Options empty, then the blog is displayed on the frontpage, but the blog page in the menu is empty. In this case the b;log page shows my chosen subtitel, but the frontpage doesn’t. Instead it says in the title “Blog – Latest news”. I don’t know where that is coming from and where is my subtitle gone?

    I am a wordpress newbie (as you might have guessed). Please help me with this issue!




    Hi Maren,

    What you’ll want to do is go to Pages > Add New and create a new page called “Home”. After you’ve done that go to Angular > Template Builder and create a new template called “Blog on Frontpage”.

    Now click on “Blog on Frontpage” in the side menu. Under “Dynamic Template Page Layout” select either Full Width (if you don’t want a sidebar), Left sidebar or Right sidebar.

    Under “Add Elements” select Blog from the dropdown list and click Add Element. If you click the down arrow on the Blog tab you’ll have several options you can choose from like how many posts to display, which category to display, etc. (Note: You can add other elements as you see fit so you may want to play around.)

    Once done, click the Save All Changes button then go back to Pages > “Home”. On the right side in the “Layout” box under “Dynamic Template” choose “Blog on Frontpage” then click the Update button.

    Now for the final step go to Angular > Theme Options and select “Home” under the “Frontpage Settings” and your “Blog” under your “Blog Settings”.

    Let us know if you have any questions.




    Hey Mya!

    Thanks – you’re a genius! This is working well.

    Thanks for replying so quickly and for giving so precise instructions. This was very helpful!





    Glad Mya could help.



Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Blog on frontpage stays empty’ is closed to new replies.